summaryrefslogtreecommitdiff
path: root/kde-apps/kdenlive/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /kde-apps/kdenlive/files
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'kde-apps/kdenlive/files')
-rw-r--r--kde-apps/kdenlive/files/kdenlive-18.04.0-qt-5.11.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/kdenlive/files/kdenlive-18.04.0-qt-5.11.patch b/kde-apps/kdenlive/files/kdenlive-18.04.0-qt-5.11.patch
new file mode 100644
index 000000000000..9b65000a8cb5
--- /dev/null
+++ b/kde-apps/kdenlive/files/kdenlive-18.04.0-qt-5.11.patch
@@ -0,0 +1,41 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -78,7 +78,7 @@
+ check_include_files(malloc.h HAVE_MALLOC_H)
+ check_include_files(pthread.h HAVE_PTHREAD_H)
+
+-find_package(Qt5 REQUIRED COMPONENTS Core DBus Widgets Script Svg Quick )
++find_package(Qt5 REQUIRED COMPONENTS Core DBus Widgets Script Svg Quick Concurrent)
+ find_package(Qt5 OPTIONAL_COMPONENTS WebKitWidgets QUIET)
+
+ find_package(KF5 5.23.0 OPTIONAL_COMPONENTS XmlGui QUIET)
+diff --git a/renderer/CMakeLists.txt b/renderer/CMakeLists.txt
+--- a/renderer/CMakeLists.txt
++++ b/renderer/CMakeLists.txt
+@@ -9,12 +9,6 @@
+ add_executable(kdenlive_render ${kdenlive_render_SRCS})
+ ecm_mark_nongui_executable(kdenlive_render)
+
+-qt5_use_modules(kdenlive_render Widgets Concurrent DBus)
+-
+-target_link_libraries(kdenlive_render
+- ${QT_LIBRARIES}
+- ${Qt5_LIBRARIES}
+-)
+-
++target_link_libraries(kdenlive_render Qt5::Core Qt5::DBus)
+
+ install(TARGETS kdenlive_render DESTINATION ${BIN_INSTALL_DIR})
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -299,7 +299,7 @@
+ target_link_libraries(kdenlive KF5::Crash)
+ endif()
+
+-qt5_use_modules( kdenlive Script Widgets Concurrent Qml Quick)
++target_link_libraries(kdenlive Qt5::Script Qt5::Widgets Qt5::Concurrent Qt5::Qml Qt5::Quick)
+
+ if (Qt5WebKitWidgets_FOUND)
+ message(STATUS "Found Qt5 WebKitWidgets. You can use your Freesound.org credentials to download files")