summaryrefslogtreecommitdiff
path: root/kde-apps/kaccounts-integration/kaccounts-integration-17.08.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-apps/kaccounts-integration/kaccounts-integration-17.08.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-apps/kaccounts-integration/kaccounts-integration-17.08.1.ebuild')
-rw-r--r--kde-apps/kaccounts-integration/kaccounts-integration-17.08.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-apps/kaccounts-integration/kaccounts-integration-17.08.1.ebuild b/kde-apps/kaccounts-integration/kaccounts-integration-17.08.1.ebuild
new file mode 100644
index 000000000000..ffa2bd529195
--- /dev/null
+++ b/kde-apps/kaccounts-integration/kaccounts-integration-17.08.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALDBUS_TEST="true"
+inherit kde5
+
+DESCRIPTION="Administer web accounts for the sites and services across the Plasma desktop"
+HOMEPAGE="https://community.kde.org/KTp"
+LICENSE="LGPL-2.1"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ >=net-libs/libaccounts-glib-1.21
+ net-libs/signond
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_plasma_dep kde-cli-tools)
+ sys-devel/gettext
+"
+
+# bug #549444
+RESTRICT+=" test"