summaryrefslogtreecommitdiff
path: root/kde-apps/juk/juk-17.04.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /kde-apps/juk/juk-17.04.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'kde-apps/juk/juk-17.04.3.ebuild')
-rw-r--r--kde-apps/juk/juk-17.04.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-apps/juk/juk-17.04.3.ebuild b/kde-apps/juk/juk-17.04.3.ebuild
new file mode 100644
index 000000000000..00bc156df39e
--- /dev/null
+++ b/kde-apps/juk/juk-17.04.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+QT3SUPPORT_REQUIRED="true"
+inherit kde4-base
+
+DESCRIPTION="Jukebox and music manager by KDE"
+HOMEPAGE="https://www.kde.org/applications/multimedia/juk/"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="
+ media-libs/phonon[qt4]
+ >=media-libs/taglib-1.6
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # bug 410551: for disabling deprecated TunePimp support
+ local mycmakeargs=(
+ -DWITH_TunePimp=OFF
+ )
+
+ kde4-base_src_configure
+}