summaryrefslogtreecommitdiff
path: root/kde-apps/incidenceeditor/incidenceeditor-18.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /kde-apps/incidenceeditor/incidenceeditor-18.12.3.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'kde-apps/incidenceeditor/incidenceeditor-18.12.3.ebuild')
-rw-r--r--kde-apps/incidenceeditor/incidenceeditor-18.12.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-apps/incidenceeditor/incidenceeditor-18.12.3.ebuild b/kde-apps/incidenceeditor/incidenceeditor-18.12.3.ebuild
new file mode 100644
index 000000000000..21a7ce6d9f3e
--- /dev/null
+++ b/kde-apps/incidenceeditor/incidenceeditor-18.12.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Incidence editor for korganizer"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep eventviews)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdepim-apps-libs)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kldap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/kdiagram:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"