summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /kde-apps/dolphin
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest2
-rw-r--r--kde-apps/dolphin/dolphin-18.04.0.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 6dc0db066daf..5696cc4ebd29 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-17.12.3.tar.xz 4841752 BLAKE2B 1f58cb0f1663e131a1b8dc58fc47d40a8a68bcb998fd3c6191f99176263523d40c1d9057b569c10c14e2a6b0be91b2eaaf07a54acdd386984d0da167cb84fabd SHA512 44cf8baaeead69dd5529ce7da96d78f507029fa47ac9ac50de9d77cb15335dd0b0e0c916f2cdd0d5cadc465e461115dbfd02c51af38d03da985d66bd22456136
+DIST dolphin-18.04.0.tar.xz 4843460 BLAKE2B 408e0c3797885a80d128247f178e4b966fdd280c5538fcccd40e4cee7bde6d7821616df098e28b79fcd3136a6b14b654ee053ff6bee0c6424613e9560bf55f01 SHA512 9c941c37d8c1b132c092a3c71f75b821427b170ded6be8a0d1ca19a5807c9c2689cd695ee8e953443e2769358e3a28704c1880671a1fa0daaae9c1149cc12642
EBUILD dolphin-17.12.3.ebuild 2230 BLAKE2B 8e3d435eac7d521830bbd13122d7616bc5c54b786eef8386dad3c9b97447058a843d61c060308518c84e776787cdeb0e1b3399fc099f69faa6b7f055eae79c58 SHA512 b3999175d7bf0672fce3b697104b9fb024c9d0487dad8a40d1f37405ca7d611b2981a76629c024eb06cf7503c900a2a2d70c365d718fd8b173562103f1db975b
+EBUILD dolphin-18.04.0.ebuild 2232 BLAKE2B b4f046f19a528c78bf029e0a7834c4bee8759c053fdafb3c7cc199f527981090eb670b70fcff76854071a7fd656bc30da75b96cc60661724a0a54f0d3774a62f SHA512 d1fe6680f462eb3ee58bd6e12d13d0cf9594dbf14b8a4521d241c62e3a2a7d46e74b9a61120450a5037a9f9c61d349b0a0975c208fa0759e667788d4495b7fa5
MISC metadata.xml 331 BLAKE2B a91c4bcb2198a9547445e94220760e327f2cfd2225e4189b4d5ec23ade31bd0c2560403cd085d91430fcde303df0cf25477b840aeda3010f332a3f053aa5aeaf SHA512 2946556cf6d92f1d2c33c44b4b261003d6e26f2829944082422afceab77f7a504dac7cc945fddaa0539953884b57a41dcc8f2f8b972b48fb4dca502b8a92d367
diff --git a/kde-apps/dolphin/dolphin-18.04.0.ebuild b/kde-apps/dolphin/dolphin-18.04.0.ebuild
new file mode 100644
index 000000000000..256cdd947622
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-18.04.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://www.kde.org/applications/system/dolphin https://userbase.kde.org/Dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs)
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ fi
+}