summaryrefslogtreecommitdiff
path: root/kde-apps/dolphin-plugins-git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /kde-apps/dolphin-plugins-git
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'kde-apps/dolphin-plugins-git')
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest2
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 09db8313d876..3ced066db6a5 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,3 +1,5 @@
DIST dolphin-plugins-19.04.3.tar.xz 191524 BLAKE2B 8869c9e5c4de20b64ad426db82ce2249821f2bf6ceec958f55b385b16c3c85af7b4e908a37f422e79454ee1ba4f604e1ed9a4ef7ba7ff431dffb32d7443c55e3 SHA512 5a89daee3a4366905bd5c884460b62b9faf75989f8bb9b108f019c4359c5ea6406efcaf896a3504870819467130cd76e31a92cf9d697a5306293b5efd701e4c3
+DIST dolphin-plugins-19.08.0.tar.xz 192076 BLAKE2B 78fcaff0e607932eeab04c3136d0b0be83bd92dbf09bbf5f4ee10a74f64f142e667023375646a484cfaa865070ee2be52f47daedce68274420e3ea9e0d8c4e80 SHA512 122b584fecc0a891688047d808d6e5736fc8521004930fa9559436e24e49b3851f6aaa9f19a3d8ac31654c2f068cf6b885269de35a8ac7e09faa56b67fb2a0ac
EBUILD dolphin-plugins-git-19.04.3.ebuild 1102 BLAKE2B 9a8cff732d041ffb70a6a0c2ec126c04e523f001393319b550125a5a845086cc7a133ba3c11ddc7156183e0819735cafa63001c25d8d4ad5a0499a72a668d7c6 SHA512 394af0335d93282c7321a84a3ff676f8e123305c00319a71c515d3c3efcf0ada3c604a816d3aa9a7556a9513762e2d233fd08c1197b701577ca78d6901f7bbc0
+EBUILD dolphin-plugins-git-19.08.0.ebuild 1105 BLAKE2B 43bcecd00bc1b09a28e5670b2c551b055ba6e4ad3130f07984d0a1e3b74a5154c271b7939f934c0acc6b24d71c782bdc915b25c4e7c0726fa59d6b43098cf6b2 SHA512 412341129a5125b9e3b1ffa0956036a904176c7a9c66462de105fbf55618dc529ae4d6461c291f5f9aa2639f31b4e8410fdf9617bdeef5898048b8d1cb863424
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.0.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.0.ebuild
new file mode 100644
index 000000000000..1c11cb316cb2
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-19.08.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="git"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Git integration"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/git
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ punt_bogus_dep Qt5 Network
+ punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}