summaryrefslogtreecommitdiff
path: root/kde-apps/ark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /kde-apps/ark
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest3
-rw-r--r--kde-apps/ark/ark-18.04.0.ebuild77
-rw-r--r--kde-apps/ark/files/ark-18.04.0-missing-memory-include.patch35
3 files changed, 115 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index e505c246e5e8..7bab5d49ccbe 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,3 +1,6 @@
+AUX ark-18.04.0-missing-memory-include.patch 934 BLAKE2B d371207e04b2c05b3fe54e5dace192ca6a6c5d58225f72ec4c40f638167825ca29219528df259b8d000547e26a5fc7347791d8620efb82658f8bc2039a7c6323 SHA512 01b1e7aa6c0190909ca0bbb207b29c0fa631910fefc0a07c2d16e2b2884eb9ede3bff2a49d3a65c54331c06003cc3093c5d4aba2fdc7b500d03e999ef268a192
DIST ark-17.12.3.tar.xz 1970120 BLAKE2B b8e14f6b5f541c514107cf76b612edd99d6e0d97dfbe7600349bdcf2bd5afbfd1fcaf256d0358ff0c8838d8334a14ddd1ac5d29ce9befebe960444e0828aba5e SHA512 2f32f0107afa20ef115caddaf3c7ce6be37a575c72ea440f571312309d945a0e0491a4327db379e8ca7622a2b5016c5b2bbbfb3377d3b4272430f85b23fbb911
+DIST ark-18.04.0.tar.xz 1969376 BLAKE2B 9d1e017c0d37307b8f8b9c7c0f9ec2be0d856c97cd39e0d928cd201553543883941baa4226a035e1cce9049125a80bde0d9a20da1159823bcc5d23be0fdaabff SHA512 0a6ab705bfec8af43c847f50580e97452e29ad83f34271ba09f5ec5eacefafe09b312149565ea802e25cf15597ecd78108e2581ebf52396af22f52aa228de69f
EBUILD ark-17.12.3.ebuild 1834 BLAKE2B 89c23fab134592a27905dd66a4598b20df701ff11e9d2716b6015c85ee789779b90ac04077c4894544fd9e9cf92a878dd0cfa24f131d13075079aa29ff4cef37 SHA512 4577863a920fb488b2f275a78e74427176e4c2680ab604b6fe96c3e96ecacf692b1c757e09c787fb4a9a4b386094db4e1687d3fe61118ba570e9908201e06ff8
+EBUILD ark-18.04.0.ebuild 1897 BLAKE2B 39a6778e422f891e5b32d22fc3d7f38ec7a92771fc88e8fcb77cb54e0a10ebfec7ced8ae3264a6cb519035df19eea9886203a56fbcc8dd3f8481afcb4a45961e SHA512 f3d847f502c9eb86f29187d85d3448d16accaaf103cc39ad9f50be7b6e2b27c766aa4135c3b0609c6a81fde2fa552decf3a9aa70dee021df7fadda32f1716787
MISC metadata.xml 348 BLAKE2B 89cd42a24774f85082d025bc18402e0d4a36e07ab62155b67474a14c7294de3875d078167521f6cc4496f97f311de9264ff8c41e78477101a80d0ae2a034dcaf SHA512 447d60adfaec4e52c25d7a61a281b8b044c9a786a0600b8a8260a150f6842047f45b981aabb75e56255d05a918370113f6d2552fec1b88f661141453e003c472
diff --git a/kde-apps/ark/ark-18.04.0.ebuild b/kde-apps/ark/ark-18.04.0.ebuild
new file mode 100644
index 000000000000..273b2b1ad902
--- /dev/null
+++ b/kde-apps/ark/ark-18.04.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-missing-memory-include.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}
diff --git a/kde-apps/ark/files/ark-18.04.0-missing-memory-include.patch b/kde-apps/ark/files/ark-18.04.0-missing-memory-include.patch
new file mode 100644
index 000000000000..1935fc4ccaeb
--- /dev/null
+++ b/kde-apps/ark/files/ark-18.04.0-missing-memory-include.patch
@@ -0,0 +1,35 @@
+From 23ce7f8c727d76d4532b8949c383c3f17b64a539 Mon Sep 17 00:00:00 2001
+From: Marco Genasci <fedeliallalinea@gmail.com>
+Date: Fri, 20 Apr 2018 11:40:30 +0200
+Subject: [PATCH] libzipplugin: Add missing <memory> header
+
+Summary:
+Build fails on some setups for use of std::unique_ptr.
+See also: https://bugs.gentoo.org/653546
+
+Reviewers: #ark
+
+Subscribers: kde-utils-devel
+
+Tags: #ark
+
+Differential Revision: https://phabricator.kde.org/D12374
+---
+ plugins/libzipplugin/libzipplugin.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/plugins/libzipplugin/libzipplugin.cpp b/plugins/libzipplugin/libzipplugin.cpp
+index 5641c97b..be260b39 100644
+--- a/plugins/libzipplugin/libzipplugin.cpp
++++ b/plugins/libzipplugin/libzipplugin.cpp
+@@ -41,6 +41,7 @@
+
+ #include <utime.h>
+ #include <zlib.h>
++#include <memory>
+
+ K_PLUGIN_FACTORY_WITH_JSON(LibZipPluginFactory, "kerfuffle_libzip.json", registerPlugin<LibzipPlugin>();)
+
+--
+2.17.0
+