summaryrefslogtreecommitdiff
path: root/kde-apps/ark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /kde-apps/ark
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest2
-rw-r--r--kde-apps/ark/ark-19.04.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 566c440a7de6..2006a307a61c 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,3 +1,5 @@
DIST ark-18.12.3.tar.xz 2580024 BLAKE2B a705da9af77ff8fdebbdb2fa3a58fa2a33ccba8a297b6def20ee855b8c5f05ecc90a4f14dc29aae632f8f9dfcb996ea01660ddfd49edce942e042a89b8d51dc1 SHA512 0dc232b004134c048bb516aa43e478545b4052fba9321a6166a3bb4e05638288802f578cea51340c8416257f10e1bcbd55740a8945ae5f95cee6864f107d633f
+DIST ark-19.04.0.tar.xz 2582636 BLAKE2B 2a1d035faf8c1bcfcddb27442e9b245a95a2866b51678cd7489239f0bf4821d3bcf2f4a9228891006db5b4b21080b37f62d19fd55227717bd4ac19241d58fd05 SHA512 7bcc2a98706644fc0a30bd04f40becea240c245f8fd8af941f893f4a1fe11c8e8f5ce6a9303f8172fed30db953110ce7cb7c4e50132f0392cd92ae9d02390bb5
EBUILD ark-18.12.3.ebuild 2058 BLAKE2B 2aeafdafafbde3b1a4787c77df5e3c8dee256edb9890ad41bf342844725d21a7fa089d4cc63fad6ce9bd0030e2cb9cb9a7725a254516898ef0ab8938997a69f6 SHA512 1b1e5d710789713021a545a661fc05c8f3cf8c8033fc31ca78f2c6722d68d6f63e7be1b24cc6ed4341a935debbb4a1312043b3b98ee8d5ff86d8888a0bda098f
+EBUILD ark-19.04.0.ebuild 2056 BLAKE2B 92f61a8188e5b799170c4f90d7510b4773d8cbe49ad8593261a55ba8fff0b032065cd7c6dd34ff74da692f06982ae1fc552e9358556244ce79e3928f0db0b55a SHA512 00af0a51d5dc2f4f702667e0ab8ba207381c61d7c6a151b282ff31fd9b734b3178c5c830362df70207f5f6c14461ce07ec39a87ca67c9c8959a8498e13d6c299
MISC metadata.xml 348 BLAKE2B 89cd42a24774f85082d025bc18402e0d4a36e07ab62155b67474a14c7294de3875d078167521f6cc4496f97f311de9264ff8c41e78477101a80d0ae2a034dcaf SHA512 447d60adfaec4e52c25d7a61a281b8b044c9a786a0600b8a8260a150f6842047f45b981aabb75e56255d05a918370113f6d2552fec1b88f661141453e003c472
diff --git a/kde-apps/ark/ark-19.04.0.ebuild b/kde-apps/ark/ark-19.04.0.ebuild
new file mode 100644
index 000000000000..bba063801ed4
--- /dev/null
+++ b/kde-apps/ark/ark-19.04.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="bzip2 lzma zip"
+
+BDEPEND="
+ sys-devel/gettext
+"
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version app-arch/rar; then
+ elog "For creating/extracting rar archives, installing app-arch/rar is required."
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "Alternatively, for only extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+ fi
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+ fi
+}