summaryrefslogtreecommitdiff
path: root/kde-apps/ark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /kde-apps/ark
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest2
-rw-r--r--kde-apps/ark/ark-18.08.1.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index bf0dea72d7e6..be3f00374c89 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,3 +1,5 @@
DIST ark-18.04.3.tar.xz 1973656 BLAKE2B afa413156233a31a1c7d102799b347b6879453a4c0a870511cb9040c9160c4da4eab30722ad9ec07ec1e9b68e942c137c464e0054738d8ee3632546b49c9dc93 SHA512 39348d3cbd3ed044ecc40a235c3e93dacb638e3ea867f814c722630786fbf7ea48643f967fb46f3358c64966a250306f11ab2a76c9147bc135ba826bcce9d33d
+DIST ark-18.08.1.tar.xz 2580104 BLAKE2B cee3333c426ebd896ed012e1cce4326cae87a5b604d712cb71d6716b485f57149d8ca06fc908e01c00f3e848d0a6f5612031127f1e53ed2fdf6d3e0d9211f516 SHA512 b4daf4f438a084df452063556a1754856a56a9a97db2c8379775d9803bc262447f7fed983c4a04e046f2a5e673ae43e4f3a902854912f79da14b9080c9970eaf
EBUILD ark-18.04.3.ebuild 1942 BLAKE2B 33c6fa57d3e3fca99e18c2cef0c2505ff239ea66f2f5bbc9fb177b293344c2b16360021902046fcbafc5ec6e71496fc47a96a07a849ae0a9cb75085d142bab9e SHA512 05f9578df0799c444409bac6ef1c7ac1824493a7080af68d9f908ef0a7bd6348722d2c2c2fdfd9e1e57296d7b5823416869cf57438def2e58942857db267e78a
+EBUILD ark-18.08.1.ebuild 1944 BLAKE2B 3f014c4d6621f7d41dbc11852b11b513ec6844bf73548e22461e503b7afaa2eba1e00a75a3286b4a355c473bd50c988a039c49b8195da3fbf92a2304fd5bacb4 SHA512 2aa41369da96eb37e926d8e8cced96313e30a9356fb96011aee678c29e4afde5b0e32d62734dd88e57fe6f6b32d9f699dac9429cee34a2333c519e639dd4fab5
MISC metadata.xml 348 BLAKE2B 89cd42a24774f85082d025bc18402e0d4a36e07ab62155b67474a14c7294de3875d078167521f6cc4496f97f311de9264ff8c41e78477101a80d0ae2a034dcaf SHA512 447d60adfaec4e52c25d7a61a281b8b044c9a786a0600b8a8260a150f6842047f45b981aabb75e56255d05a918370113f6d2552fec1b88f661141453e003c472
diff --git a/kde-apps/ark/ark-18.08.1.ebuild b/kde-apps/ark/ark-18.08.1.ebuild
new file mode 100644
index 000000000000..7a5bb558b1c2
--- /dev/null
+++ b/kde-apps/ark/ark-18.08.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "For extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+
+ has_version app-arch/rar || \
+ elog "For creating rar archives, installing app-arch/rar is required."
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+}