summaryrefslogtreecommitdiff
path: root/kde-apps/akonadiconsole/akonadiconsole-19.04.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /kde-apps/akonadiconsole/akonadiconsole-19.04.3.ebuild
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'kde-apps/akonadiconsole/akonadiconsole-19.04.3.ebuild')
-rw-r--r--kde-apps/akonadiconsole/akonadiconsole-19.04.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-apps/akonadiconsole/akonadiconsole-19.04.3.ebuild b/kde-apps/akonadiconsole/akonadiconsole-19.04.3.ebuild
new file mode 100644
index 000000000000..303ffc47eb2d
--- /dev/null
+++ b/kde-apps/akonadiconsole/akonadiconsole-19.04.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+inherit kde5
+
+DESCRIPTION="Application for debugging Akonadi Resources"
+LICENSE="GPL-2+ LGPL-2.1+ handbook? ( FDL-1.2+ )"
+HOMEPAGE="https://kde.org/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-search)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkdepim)
+ $(add_kdeapps_dep messagelib)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ dev-libs/xapian:=
+"
+RDEPEND="${DEPEND}"