summaryrefslogtreecommitdiff
path: root/kde-apps/akonadi-search/akonadi-search-18.04.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /kde-apps/akonadi-search/akonadi-search-18.04.0.ebuild
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'kde-apps/akonadi-search/akonadi-search-18.04.0.ebuild')
-rw-r--r--kde-apps/akonadi-search/akonadi-search-18.04.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/akonadi-search/akonadi-search-18.04.0.ebuild b/kde-apps/akonadi-search/akonadi-search-18.04.0.ebuild
new file mode 100644
index 000000000000..5504a5b85b7b
--- /dev/null
+++ b/kde-apps/akonadi-search/akonadi-search-18.04.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="forceoptional-recursive"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Libraries and daemons to implement searching in Akonadi"
+HOMEPAGE="https://cgit.kde.org/akonadi-search.git"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep krunner)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ >=dev-libs/xapian-1.3:=[chert]
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ test? ( $(add_kdeapps_dep akonadi 'mysql,postgres,sqlite,tools') )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-l10n
+"