summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
commitf0ddcad13515f66d2f3bf827d33c277bdba7e1dd (patch)
tree3e1da8fa4626163bda62e9e8b6129867de5be46d /gui-wm
parent65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (diff)
gentoo auto-resync : 12:06:2024 - 00:08:13
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/Manifest.gzbin1213 -> 1379 bytes
-rw-r--r--gui-wm/tinywl/Manifest4
-rw-r--r--gui-wm/tinywl/metadata.xml15
-rw-r--r--gui-wm/tinywl/tinywl-0.17.3.ebuild47
-rw-r--r--gui-wm/tinywl/tinywl-9999.ebuild47
5 files changed, 113 insertions, 0 deletions
diff --git a/gui-wm/Manifest.gz b/gui-wm/Manifest.gz
index 763333434fde..b5188ded1ec4 100644
--- a/gui-wm/Manifest.gz
+++ b/gui-wm/Manifest.gz
Binary files differ
diff --git a/gui-wm/tinywl/Manifest b/gui-wm/tinywl/Manifest
new file mode 100644
index 000000000000..ae2b5172ce3f
--- /dev/null
+++ b/gui-wm/tinywl/Manifest
@@ -0,0 +1,4 @@
+DIST wlroots-0.17.3.tar.gz 608292 BLAKE2B 7caab3c3a58595d3a745c0b20a5db2193c54931cdd7bc1b9de11c151af82503a03a6a3166a86f42486cc69c6ac18ca2a5596809a5c5e6d7b44c9845f509c1093 SHA512 b88747daba304db6dc302acdebb8764e719d84134118963c019d5f0d0d38552e0ffd2a50bf560b3b84549c5a0f2d11a6187ac8ddcd9faa28c5b42f86c585b555
+EBUILD tinywl-0.17.3.ebuild 983 BLAKE2B aed9211a01589fa6af1ce05a3aa3439cfd18e71e7e646d1e847e30623444ad66014b0707f0eeba14dd5c69999ea7771ec1d46fc71cdf64e869a66df40c008548 SHA512 7bca5e23bd4a0499806f764591655fad090c47f84666e5cb00f54f37bb2e785fb9ddc1665f429eb95e030d139d227e636454b0888bbaf39654b328ff9f5b9fe8
+EBUILD tinywl-9999.ebuild 957 BLAKE2B aa39010c6890743a632847da721202ba37ec86d2065ee6c203a9ae429a6ef2ea99e244b23983c5208932c594ab1b16120a4069958fb5e4b118979e325ac89aab SHA512 ba9991205ebbf941516bac0dd46aaeabd5c07d660cb80c8c01f9418060e98f0e0cf7bd195d4ea505d760f31665b05d5e97957db5c082981ee2b487545eddd217
+MISC metadata.xml 505 BLAKE2B dceb764d020ca749f5f5c82b310b2357ec234b93afe377b1b8bcff210c9cc85300bcae834d0a7b772a76378f28edae24d6b5c12eaaa00795ff0ffb4c486ae2e4 SHA512 c142b3f1637209f1f43fcb4123435cf10e643fabff9473f98aa754bca3fe6dc8cec66851d2086658e56191919455eae3ed7d5ef3fa0d85391d1c7b82045b2787
diff --git a/gui-wm/tinywl/metadata.xml b/gui-wm/tinywl/metadata.xml
new file mode 100644
index 000000000000..c478e8b9eaf9
--- /dev/null
+++ b/gui-wm/tinywl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>leohdz172@proton.me</email>
+ <name>Leonardo Hernández Hernández</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">wlroots/wlroots</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-wm/tinywl/tinywl-0.17.3.ebuild b/gui-wm/tinywl/tinywl-0.17.3.ebuild
new file mode 100644
index 000000000000..671c3ed50e4a
--- /dev/null
+++ b/gui-wm/tinywl/tinywl-0.17.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="\"minimum viable product\" Wayland compositor based on wlroots"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/${PV}/downloads/wlroots-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/wlroots-${PV}"
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+DEPEND="
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+RDEPEND="
+ ${DEPEND}
+ !gui-libs/wlroots[tinywl(-)]
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "s/-Werror //" tinywl/Makefile || die
+ default
+}
+
+src_compile() {
+ emake -C tinywl
+}
+
+src_install() {
+ dodoc tinywl/README.md
+ dobin tinywl/tinywl
+}
diff --git a/gui-wm/tinywl/tinywl-9999.ebuild b/gui-wm/tinywl/tinywl-9999.ebuild
new file mode 100644
index 000000000000..891403933f45
--- /dev/null
+++ b/gui-wm/tinywl/tinywl-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="\"minimum viable product\" Wayland compositor based on wlroots"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wlroots/wlroots/-/releases/${PV}/downloads/wlroots-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/wlroots-${PV}"
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+DEPEND="
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+RDEPEND="
+ ${DEPEND}
+ !gui-libs/wlroots[tinywl(-)]
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "s/-Werror //" tinywl/Makefile || die
+ default
+}
+
+src_compile() {
+ emake -C tinywl
+}
+
+src_install() {
+ dodoc tinywl/README.md
+ dobin tinywl/tinywl
+}