summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 02:52:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 02:52:00 +0100
commite19b21c73e5feac42ade97baf3eeb45c58a2f234 (patch)
treef524a01a657ca0dd25be3a5bf70fbb6b694b0275 /gui-wm
parentfceabcd48faf4c890719a14ac4ed93b6b7993364 (diff)
gentoo auto-resync : 24:07:2022 - 02:51:59
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/Manifest.gzbin718 -> 721 bytes
-rw-r--r--gui-wm/sway/Manifest3
-rw-r--r--gui-wm/sway/sway-1.7-r2.ebuild113
-rw-r--r--gui-wm/sway/sway-9999.ebuild32
4 files changed, 136 insertions, 12 deletions
diff --git a/gui-wm/Manifest.gz b/gui-wm/Manifest.gz
index 59818796f009..ae42892b552a 100644
--- a/gui-wm/Manifest.gz
+++ b/gui-wm/Manifest.gz
Binary files differ
diff --git a/gui-wm/sway/Manifest b/gui-wm/sway/Manifest
index 5836fb817433..f17699e8d209 100644
--- a/gui-wm/sway/Manifest
+++ b/gui-wm/sway/Manifest
@@ -1,5 +1,6 @@
DIST sway-1.7.tar.gz 5559075 BLAKE2B 702b9a209d603c88743f2e89d0787431b7a30e8b7554c9596edb9735af862d23c585158737a0943a470637138cbc5275bee37bd2d820a7489cdd0747d98e6e22 SHA512 028cf5d504d5914bfb78d44156d6a290de660c5ed0638f4e2c56e5be76db9b0baeda035e1fa1ae23559016bd7e4312f7ff70c2fb4904df25358577c1a3d21243
EBUILD sway-1.7-r1.ebuild 2175 BLAKE2B 9847fd44899ef922fa04ddfeb810b0ad4c9ae930f785c2393b6b5e1d348c893b19c0e9f791fbd661b76eed3e4c4f9eb16ecaac1c794479f1e86680180eb115e9 SHA512 c25c1776915883c42113c358783706181402c5f052ef08a81c20380af4bae37da5e3c53b59f0ac9d6bdfc197f94b33ba713830d9e85ad4a9ed74d5b3825fd85d
+EBUILD sway-1.7-r2.ebuild 2629 BLAKE2B 09ae1cd2a056ff6b775225ecc3fd81012fdd44d66cd2ec97e68874148872931a09b4ca9988fbf10287f9b032ac4e8f52766ef8f44a2b052f41aaaf381d515aec SHA512 88398a3f549b9c356c305df3a40a86987a842c05df320826195230585ca7da2a9c7a5f65f62ef73f9fe8c7f331926c8b5efb18bfd0e064ef8a2e00552f5ba94e
EBUILD sway-1.7.ebuild 1900 BLAKE2B 7969c477bc7a65cb67ad007e9105c7046af2a873bd3fdd1924ed37e74f60819973ca96061dbb5b97fedd20d47bd1832f939c4ad9ae0885c2549dc03972f980b4 SHA512 a702d1a00d4019c72e0bd54262ac4d0d7304835df6cbd92e93f94e8aee56f556331b0452c10c4dd3e221cd31fd04859804f62027d1080a2c1fece797b9359bdb
-EBUILD sway-9999.ebuild 2175 BLAKE2B 4fedd4d1dc45409a149fbfd112b055bb7921ccde21504fd1a88fe427c1b36ea5b4abb93d7e4a9aff9836bb5fb3d94ebb006724e8dcc825f6d88b8a02e428d9b4 SHA512 cb7b7b1972e7ecc104aa7203bb2f4925ff3dce838faeb6de818dfea5a468080d76c5c7f7c0584409bd0fa11014e37368b256cf6bddab6ac165f56f4cd19e6629
+EBUILD sway-9999.ebuild 2629 BLAKE2B cc04a618400c1acf3cbc9fc5e09eaaca2858a4950b987279a640101154dc164930f9a33c3f85c8919c278323d2a84cc6793e5872d8c2418fd8e2eb2a5ad364b9 SHA512 40bccbd3421981f061576a265369bb3da7b60ae1d27cff992e22bfc2cca8bfa1685708f47ecba2424028069507c5636b94165a287472c797175e458a3b2599d4
MISC metadata.xml 2269 BLAKE2B 75c8e2e2550cdb3ca970806b724068e0e78d3b9f70dba320db25fe8637ecc5c70ebba9a9d604d30e8a79f2155949e9aabb0993e3fbb8fe4b626c471231eeb46f SHA512 07c978ed2c7e351b0f72c69e707c409344bdbf0ef1348d85b71d9876284b1f632439c74a924818d0401ad31dd2e1d328c7446dabbbda1c4db27b67cbd68d8546
diff --git a/gui-wm/sway/sway-1.7-r2.ebuild b/gui-wm/sway/sway-1.7-r2.ebuild
new file mode 100644
index 000000000000..c0c995944c3c
--- /dev/null
+++ b/gui-wm/sway/sway-1.7-r2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ MY_PV=${PV/_rc/-rc}
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
+
+DEPEND="
+ >=dev-libs/json-c-0.13:0=
+ >=dev-libs/libinput-1.6.0:0=
+ sys-auth/seatd:=
+ dev-libs/libpcre
+ >=dev-libs/wayland-1.20.0
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ media-libs/mesa[gles2,libglvnd(+)]
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ tray? ( || (
+ sys-apps/systemd
+ sys-auth/elogind
+ sys-libs/basu
+ ) )
+ wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
+ X? ( x11-libs/libxcb:0= )
+"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~gui-libs/wlroots-9999:=[X?]"
+else
+ DEPEND+="
+ >=gui-libs/wlroots-0.15:=[X?]
+ <gui-libs/wlroots-0.16:=[X?]
+ "
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ grimshot? (
+ app-misc/jq
+ gui-apps/grim
+ gui-apps/slurp
+ gui-apps/wl-clipboard
+ x11-libs/libnotify
+ )
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-util/meson-0.60.0
+ virtual/pkgconfig
+"
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+REQUIRED_USE="tray? ( swaybar )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature tray)
+ $(meson_feature X xwayland)
+ $(meson_feature swaybar gdk-pixbuf)
+ $(meson_use swaynag)
+ $(meson_use swaybar)
+ $(meson_use wallpapers default-wallpaper)
+ -Dfish-completions=true
+ -Dzsh-completions=true
+ -Dbash-completions=true
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use grimshot; then
+ doman contrib/grimshot.1
+ dobin contrib/grimshot
+ fi
+}
+
+pkg_postinst() {
+ optfeature_header "There are several packages that may be useful with sway:"
+ optfeature "wallpaper utility" gui-apps/swaybg
+ optfeature "idle management utility" gui-apps/swayidle
+ optfeature "simple screen locker" gui-apps/swaylock
+ optfeature "lightweight notification daemon" gui-apps/mako
+ echo
+ einfo "For a list of additional addons and tools usable with sway please"
+ einfo "visit the offical wiki at:"
+ einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+ einfo "Please note that some of them might not (yet) available on gentoo"
+}
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index 3c0073c3c363..8b8ee2335dc1 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson
+inherit meson optfeature
DESCRIPTION="i3-compatible Wayland window manager"
HOMEPAGE="https://swaywm.org"
@@ -20,7 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="grimshot +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag tray wallpapers X"
+IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
DEPEND="
>=dev-libs/json-c-0.13:0=
@@ -34,23 +34,20 @@ DEPEND="
x11-libs/pixman
media-libs/mesa[gles2,libglvnd(+)]
swaybar? ( x11-libs/gdk-pixbuf:2 )
- swaybg? ( gui-apps/swaybg )
- swayidle? ( gui-apps/swayidle )
- swaylock? ( gui-apps/swaylock )
tray? ( || (
sys-apps/systemd
sys-auth/elogind
sys-libs/basu
) )
- wallpapers? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
X? ( x11-libs/libxcb:0= )
"
if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[X=]"
+ DEPEND+="~gui-libs/wlroots-9999:=[X?]"
else
DEPEND+="
- >=gui-libs/wlroots-0.16:=[X=]
- <gui-libs/wlroots-0.17:=[X=]
+ >=gui-libs/wlroots-0.16:=[X?]
+ <gui-libs/wlroots-0.17:=[X?]
"
fi
RDEPEND="
@@ -74,7 +71,7 @@ if [[ ${PV} == 9999 ]]; then
else
BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
fi
-REQUIRED_USE="grimshot? ( swaymsg )"
+REQUIRED_USE="tray? ( swaybar )"
src_configure() {
local emesonargs=(
@@ -101,3 +98,16 @@ src_install() {
dobin contrib/grimshot
fi
}
+
+pkg_postinst() {
+ optfeature_header "There are several packages that may be useful with sway:"
+ optfeature "wallpaper utility" gui-apps/swaybg
+ optfeature "idle management utility" gui-apps/swayidle
+ optfeature "simple screen locker" gui-apps/swaylock
+ optfeature "lightweight notification daemon" gui-apps/mako
+ echo
+ einfo "For a list of additional addons and tools usable with sway please"
+ einfo "visit the offical wiki at:"
+ einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+ einfo "Please note that some of them might not (yet) available on gentoo"
+}