summaryrefslogtreecommitdiff
path: root/gui-wm/wayfire
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /gui-wm/wayfire
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'gui-wm/wayfire')
-rw-r--r--gui-wm/wayfire/Manifest4
-rw-r--r--gui-wm/wayfire/metadata.xml23
-rw-r--r--gui-wm/wayfire/wayfire-0.4.0.ebuild97
-rw-r--r--gui-wm/wayfire/wayfire-9999.ebuild97
4 files changed, 221 insertions, 0 deletions
diff --git a/gui-wm/wayfire/Manifest b/gui-wm/wayfire/Manifest
new file mode 100644
index 000000000000..661e3591eeb2
--- /dev/null
+++ b/gui-wm/wayfire/Manifest
@@ -0,0 +1,4 @@
+DIST wayfire-0.4.0.tar.xz 588904 BLAKE2B b720297b3ffb868761ea61615b4d0fefc2687f8a2060208f8cc002ff7adaf7622da906ad98e25664c3e72c04de2fb74741d0a417cce4826483407bdf10d63b43 SHA512 e96cdb90ce36c005476e08608683983aa167e58aea80fcfd3b24ab0836ec4aa50fb5a7eeb0872a1b1014e3073ed826e1c83d3146b39d3cdb2a8b3a0895155649
+EBUILD wayfire-0.4.0.ebuild 2287 BLAKE2B 83f8b62d0b931abe3da13c8dd9756ab5b283aa6667f5c89529e87a38639505b19182837f57cb01543703cbebd8cb483dd7d181479b963ff7c11b9f036dacc778 SHA512 422dfd773ec8518110076038ad8ab09337c51a0b0e7f872c7236147b302148bcbb31a3534a704e41d93a344197ac0ab1ae7b51c00d1a00b29d1dcf97df9cd2c1
+EBUILD wayfire-9999.ebuild 2287 BLAKE2B 83f8b62d0b931abe3da13c8dd9756ab5b283aa6667f5c89529e87a38639505b19182837f57cb01543703cbebd8cb483dd7d181479b963ff7c11b9f036dacc778 SHA512 422dfd773ec8518110076038ad8ab09337c51a0b0e7f872c7236147b302148bcbb31a3534a704e41d93a344197ac0ab1ae7b51c00d1a00b29d1dcf97df9cd2c1
+MISC metadata.xml 1180 BLAKE2B 5436b507ccd19b5462a9cd64bd1c0929ac6ed57a94f52945479edc60ebcf655c7f53d7eeaa871ca63c1aef9adfda5ca4c758fa470f5e1e4a422143304be993a3 SHA512 1f84c75e4ef44543221220dcbdf3ecfb9f5e0bf06e3a0b5c9a934dc36412c213c11053e29fa3b6389e7bfaf007dab8a79d9dd3a92f1fd6d30d193b8d8447d920
diff --git a/gui-wm/wayfire/metadata.xml b/gui-wm/wayfire/metadata.xml
new file mode 100644
index 000000000000..c61941f4b35f
--- /dev/null
+++ b/gui-wm/wayfire/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ compiz like eye-candy 3D wayland, with low memory footprint.
+ Aims to bring desktop features such as 3D cube, fire burn,
+ fisheye, wrot and all other desktop effects to wayland.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="gles2">use libglvnd to do animations more efficiently</flag>
+ <flag name='system-wfconfig'>use the system-wide wf-config, else build it as a submodule. DO NOT DISABLE UNLESS YOU KNOW WHAT YOU ARE DOING.</flag>
+ <flag name='system-wlroots'>use the system wide wlroots, else build it as a submodule. DO NOT DISABLE UNLESS YOU KNOW WHAT YOU ARE DOING.</flag>
+ <flag name='debug'>add debugging symbols for error reporting. DISABLE ALL SYSTEM USE FLAGS BEFORE REPORTING BUGS.</flag>
+ </use>
+</pkgmetadata>
diff --git a/gui-wm/wayfire/wayfire-0.4.0.ebuild b/gui-wm/wayfire/wayfire-0.4.0.ebuild
new file mode 100644
index 000000000000..96c6375e2b05
--- /dev/null
+++ b/gui-wm/wayfire/wayfire-0.4.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wayfire"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+gles2 +system-wfconfig +system-wlroots elogind systemd debug"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libinput
+ gui-libs/gtk-layer-shell
+ media-libs/glm
+ media-libs/mesa:=[gles2,wayland,X]
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/freetype:=[X]
+ x11-libs/libdrm
+ x11-libs/gtk+:3=[wayland,X]
+ x11-libs/cairo:=[X,svg]
+ x11-libs/libxkbcommon:=[X]
+ x11-libs/pixman
+ gles2? ( media-libs/libglvnd[X] )
+ system-wfconfig? ( ~gui-libs/wf-config-${PV}[debug=] )
+ !system-wfconfig? ( !gui-libs/wf-config )
+ system-wlroots? ( >=gui-libs/wlroots-0.10.0[elogind=,systemd=,X] )
+ !system-wlroots? ( !gui-libs/wlroots )
+"
+
+RDEPEND="
+ ${DEPEND}
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+ x11-misc/xkeyboard-config
+"
+
+BDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/wayland-protocols-1.18
+"
+
+src_compile(){
+ local emesonargs=(
+ $(meson_feature system-wfconfig use_system_wfconfig)
+ $(meson_feature system-wlroots use_system_wlroots)
+ $(meson_use gles2 enable_gles32)
+ )
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
+
+src_install() {
+ default
+ meson_src_install
+ einstalldocs
+
+ insinto "/usr/share/wayland-sessions/"
+ insopts -m644
+ doins wayfire.desktop
+
+ dodoc wayfire.ini
+
+ if ! use systemd && ! use elogind; then
+ fowners root:0 /usr/bin/wayfire
+ fperms 4511 /usr/bin/wayfire
+ fi
+}
+
+pkg_postinst() {
+ if [ -z "${REPLACING_VERSIONS}" ]; then
+ elog "Wayfire has been installed but the session cannot be used"
+ elog "until you install a configuration file. The default config"
+ elog "file is installed at \"/usr/share/doc/${P}/wayfire.ini.bz2\""
+ elog "To install the file execute"
+ elog "\$ mkdir -p ~/.config && bzcat /usr/share/doc/${P}/wayfire.ini.bz2 > ~/.config/wayfire.ini"
+ fi
+}
diff --git a/gui-wm/wayfire/wayfire-9999.ebuild b/gui-wm/wayfire/wayfire-9999.ebuild
new file mode 100644
index 000000000000..96c6375e2b05
--- /dev/null
+++ b/gui-wm/wayfire/wayfire-9999.ebuild
@@ -0,0 +1,97 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wayfire"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/${PN}.git"
+else
+ SRC_URI="https://github.com/WayfireWM/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+gles2 +system-wfconfig +system-wlroots elogind systemd debug"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libinput
+ gui-libs/gtk-layer-shell
+ media-libs/glm
+ media-libs/mesa:=[gles2,wayland,X]
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/freetype:=[X]
+ x11-libs/libdrm
+ x11-libs/gtk+:3=[wayland,X]
+ x11-libs/cairo:=[X,svg]
+ x11-libs/libxkbcommon:=[X]
+ x11-libs/pixman
+ gles2? ( media-libs/libglvnd[X] )
+ system-wfconfig? ( ~gui-libs/wf-config-${PV}[debug=] )
+ !system-wfconfig? ( !gui-libs/wf-config )
+ system-wlroots? ( >=gui-libs/wlroots-0.10.0[elogind=,systemd=,X] )
+ !system-wlroots? ( !gui-libs/wlroots )
+"
+
+RDEPEND="
+ ${DEPEND}
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+ x11-misc/xkeyboard-config
+"
+
+BDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+ >=dev-libs/wayland-protocols-1.18
+"
+
+src_compile(){
+ local emesonargs=(
+ $(meson_feature system-wfconfig use_system_wfconfig)
+ $(meson_feature system-wlroots use_system_wlroots)
+ $(meson_use gles2 enable_gles32)
+ )
+ if use debug; then
+ emesonargs+=(
+ "-Db_sanitize=address,undefined"
+ )
+ fi
+ meson_src_compile
+}
+
+src_install() {
+ default
+ meson_src_install
+ einstalldocs
+
+ insinto "/usr/share/wayland-sessions/"
+ insopts -m644
+ doins wayfire.desktop
+
+ dodoc wayfire.ini
+
+ if ! use systemd && ! use elogind; then
+ fowners root:0 /usr/bin/wayfire
+ fperms 4511 /usr/bin/wayfire
+ fi
+}
+
+pkg_postinst() {
+ if [ -z "${REPLACING_VERSIONS}" ]; then
+ elog "Wayfire has been installed but the session cannot be used"
+ elog "until you install a configuration file. The default config"
+ elog "file is installed at \"/usr/share/doc/${P}/wayfire.ini.bz2\""
+ elog "To install the file execute"
+ elog "\$ mkdir -p ~/.config && bzcat /usr/share/doc/${P}/wayfire.ini.bz2 > ~/.config/wayfire.ini"
+ fi
+}