summaryrefslogtreecommitdiff
path: root/gui-wm/sway/sway-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 02:52:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 02:52:00 +0100
commite19b21c73e5feac42ade97baf3eeb45c58a2f234 (patch)
treef524a01a657ca0dd25be3a5bf70fbb6b694b0275 /gui-wm/sway/sway-9999.ebuild
parentfceabcd48faf4c890719a14ac4ed93b6b7993364 (diff)
gentoo auto-resync : 24:07:2022 - 02:51:59
Diffstat (limited to 'gui-wm/sway/sway-9999.ebuild')
-rw-r--r--gui-wm/sway/sway-9999.ebuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index 3c0073c3c363..8b8ee2335dc1 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson
+inherit meson optfeature
DESCRIPTION="i3-compatible Wayland window manager"
HOMEPAGE="https://swaywm.org"
@@ -20,7 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="grimshot +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag tray wallpapers X"
+IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
DEPEND="
>=dev-libs/json-c-0.13:0=
@@ -34,23 +34,20 @@ DEPEND="
x11-libs/pixman
media-libs/mesa[gles2,libglvnd(+)]
swaybar? ( x11-libs/gdk-pixbuf:2 )
- swaybg? ( gui-apps/swaybg )
- swayidle? ( gui-apps/swayidle )
- swaylock? ( gui-apps/swaylock )
tray? ( || (
sys-apps/systemd
sys-auth/elogind
sys-libs/basu
) )
- wallpapers? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
X? ( x11-libs/libxcb:0= )
"
if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[X=]"
+ DEPEND+="~gui-libs/wlroots-9999:=[X?]"
else
DEPEND+="
- >=gui-libs/wlroots-0.16:=[X=]
- <gui-libs/wlroots-0.17:=[X=]
+ >=gui-libs/wlroots-0.16:=[X?]
+ <gui-libs/wlroots-0.17:=[X?]
"
fi
RDEPEND="
@@ -74,7 +71,7 @@ if [[ ${PV} == 9999 ]]; then
else
BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
fi
-REQUIRED_USE="grimshot? ( swaymsg )"
+REQUIRED_USE="tray? ( swaybar )"
src_configure() {
local emesonargs=(
@@ -101,3 +98,16 @@ src_install() {
dobin contrib/grimshot
fi
}
+
+pkg_postinst() {
+ optfeature_header "There are several packages that may be useful with sway:"
+ optfeature "wallpaper utility" gui-apps/swaybg
+ optfeature "idle management utility" gui-apps/swayidle
+ optfeature "simple screen locker" gui-apps/swaylock
+ optfeature "lightweight notification daemon" gui-apps/mako
+ echo
+ einfo "For a list of additional addons and tools usable with sway please"
+ einfo "visit the offical wiki at:"
+ einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+ einfo "Please note that some of them might not (yet) available on gentoo"
+}