summaryrefslogtreecommitdiff
path: root/gui-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-11 00:32:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-11 00:32:37 +0100
commiteccbaf6d01fb4a73c18778fa551e74960b1e0419 (patch)
tree5642d253605dc6f5812b9c055b057bdff86b26ce /gui-libs
parent008552e378e170b518a1cf572bbc8d4a0551c887 (diff)
gentoo auto-resync : 11:04:2024 - 00:32:37
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/Manifest.gzbin4761 -> 4925 bytes
-rw-r--r--gui-libs/libdecor/Manifest4
-rw-r--r--gui-libs/libdecor/libdecor-0.2.2.ebuild54
-rw-r--r--gui-libs/libdecor/libdecor-9999.ebuild54
-rw-r--r--gui-libs/libdecor/metadata.xml24
5 files changed, 136 insertions, 0 deletions
diff --git a/gui-libs/Manifest.gz b/gui-libs/Manifest.gz
index a4dcc5212f87..e7aa6e81c79c 100644
--- a/gui-libs/Manifest.gz
+++ b/gui-libs/Manifest.gz
Binary files differ
diff --git a/gui-libs/libdecor/Manifest b/gui-libs/libdecor/Manifest
new file mode 100644
index 000000000000..78019531589b
--- /dev/null
+++ b/gui-libs/libdecor/Manifest
@@ -0,0 +1,4 @@
+DIST libdecor-0.2.2.tar.bz2 45375 BLAKE2B 86e78ce5017b0babc627b5f9ce75b7e2cca38929e3c382828e0453329efed707e2c010fb51522b7b5077a616d54cf2f9af70d5b3d68d2b2aa1d6d36b7a834b8d SHA512 f9761a8c59dc85dd92c871f73192ab05eb56ea34e85a38b5a7222822173f9fd71b5bfb5cffe2782e8c0a6275100e32b6761143cb1469dbcc6988d046a09f1b9a
+EBUILD libdecor-0.2.2.ebuild 1078 BLAKE2B 51a98b64f52c79744f3a0d1dd9aeebf0579399bf04758f5d65a0835f06d495709e56b8455817d7ec78409dc445fa8af678d146431adefc266137decb9f418097 SHA512 51dc4a882d6843f21f238b88033b4861dbc08185350cc9737345c3f248b9da5af285f18417a9eaa5f04a3df809a2cfc6960954e1c49b3449e10e7af46533f9de
+EBUILD libdecor-9999.ebuild 1078 BLAKE2B 51a98b64f52c79744f3a0d1dd9aeebf0579399bf04758f5d65a0835f06d495709e56b8455817d7ec78409dc445fa8af678d146431adefc266137decb9f418097 SHA512 51dc4a882d6843f21f238b88033b4861dbc08185350cc9737345c3f248b9da5af285f18417a9eaa5f04a3df809a2cfc6960954e1c49b3449e10e7af46533f9de
+MISC metadata.xml 777 BLAKE2B 891be6d17fe0810359ae9fdd54445c62df4912b88009c44e0320c01baf141c0c9704818932a5a976f064f21091519b329e5003ad912f6cc37297f774265bfb64 SHA512 f7b56a6117961b6213cbfbd396e22881f0ef9f4c5148c70f3404cbf468dfd631364b00b90be3b73e0a5a42983994903609023d9451becea3edd9b18c16757a6a
diff --git a/gui-libs/libdecor/libdecor-0.2.2.ebuild b/gui-libs/libdecor/libdecor-0.2.2.ebuild
new file mode 100644
index 000000000000..2d21ad63368e
--- /dev/null
+++ b/gui-libs/libdecor/libdecor-0.2.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A client-side decorations library for Wayland clients"
+HOMEPAGE="https://gitlab.freedesktop.org/libdecor/libdecor"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/libdecor/libdecor.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/libdecor/libdecor/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+IUSE="+dbus +gtk examples"
+
+RDEPEND="
+ >=dev-libs/wayland-1.18
+ x11-libs/pango
+ x11-libs/cairo
+ dbus? ( sys-apps/dbus )
+ gtk? ( x11-libs/gtk+:3 )
+ examples? (
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/wayland-protocols-1.15
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # Avoid auto-magic, built-in feature of meson
+ -Dauto_features=disabled
+ $(meson_feature gtk)
+ $(meson_feature dbus)
+ $(meson_use examples demo)
+ -Dinstall_demo=true
+ )
+
+ meson_src_configure
+}
diff --git a/gui-libs/libdecor/libdecor-9999.ebuild b/gui-libs/libdecor/libdecor-9999.ebuild
new file mode 100644
index 000000000000..2d21ad63368e
--- /dev/null
+++ b/gui-libs/libdecor/libdecor-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A client-side decorations library for Wayland clients"
+HOMEPAGE="https://gitlab.freedesktop.org/libdecor/libdecor"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/libdecor/libdecor.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/libdecor/libdecor/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+IUSE="+dbus +gtk examples"
+
+RDEPEND="
+ >=dev-libs/wayland-1.18
+ x11-libs/pango
+ x11-libs/cairo
+ dbus? ( sys-apps/dbus )
+ gtk? ( x11-libs/gtk+:3 )
+ examples? (
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/wayland-protocols-1.15
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # Avoid auto-magic, built-in feature of meson
+ -Dauto_features=disabled
+ $(meson_feature gtk)
+ $(meson_feature dbus)
+ $(meson_use examples demo)
+ -Dinstall_demo=true
+ )
+
+ meson_src_configure
+}
diff --git a/gui-libs/libdecor/metadata.xml b/gui-libs/libdecor/metadata.xml
new file mode 100644
index 000000000000..9f8ba6301a8d
--- /dev/null
+++ b/gui-libs/libdecor/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="dbus">Enable dbus to query current cursor theme</flag>
+ <flag name="gtk">Build GTK plugin</flag>
+ <flag name="examples">Build and install examples</flag>
+ </use>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gonegrier.duarte@gmail.com</email>
+ <name>Gonçalo Negrier Duarte</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">libdecor/libdecor</remote-id>
+ </upstream>
+</pkgmetadata>