summaryrefslogtreecommitdiff
path: root/gui-libs/wayfire-plugins-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-13 08:16:09 +0000
commit4a74938e510c0dad732ae4c48f815dd0f0cabb46 (patch)
treee8c52cd3619bba6cf0a5c367f6c9d2cff0ac9d80 /gui-libs/wayfire-plugins-extra
parentebc282ef4dfa408accac685565b8ee5f6faec119 (diff)
gentoo auto-resync : 13:02:2023 - 08:16:09
Diffstat (limited to 'gui-libs/wayfire-plugins-extra')
-rw-r--r--gui-libs/wayfire-plugins-extra/Manifest4
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild36
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild7
3 files changed, 44 insertions, 3 deletions
diff --git a/gui-libs/wayfire-plugins-extra/Manifest b/gui-libs/wayfire-plugins-extra/Manifest
index 65c39846acac..7d144be835a4 100644
--- a/gui-libs/wayfire-plugins-extra/Manifest
+++ b/gui-libs/wayfire-plugins-extra/Manifest
@@ -1,4 +1,6 @@
DIST wayfire-plugins-extra-0.7.0.tar.xz 74312 BLAKE2B f72d706502499e4d467a4b59e10f66628024be1bab1c5e10c807758869c9b9e4aacbe426c2db0e3faa5ab166f7e4f4d0f1c345e205c6747a16a164745c6f0d74 SHA512 ff25a4685c88ca0129a2372b216166246cab072c2cb4f84eb7bd500db525bf5881bd7e54d0d888473d4aab0e5b33d2ee13eb7f788bb2a524e1e8e0c5efc1a6bd
+DIST wayfire-plugins-extra-0.7.5.tar.xz 75136 BLAKE2B 7ffbb73f09175cc92f09b8a3f0493942741564278f95ff1d80066044b02ce4ceb925919ddb54fc6a37676b925d95ea7f93d09c6b0ccd448c6e9b821106d6e3ea SHA512 9cc816c3c727b0093fd15ef52dea215598b4c49ef96c098f53938c041b3908b30f4dd616be4b459b7382d630a47b36baf845c24de84f35670ba2912711205911
EBUILD wayfire-plugins-extra-0.7.0-r1.ebuild 715 BLAKE2B 770f6c408639be29ec16702a98f36bf02e4aaf66ab87e153388d4e458d6119dfd35f7c587f1ca3844df4fb01a561d1c8b7adb34154d6d7121e9b22797fb006de SHA512 b5dee6dbdc71b904b27bf94929886008b0c94deec5e8cac02bc39ed2e4642a100eded21a6819d88017219088a4ef477f9f2856a554f64cd907815f5a83dd5295
-EBUILD wayfire-plugins-extra-9999.ebuild 684 BLAKE2B 6bedcb051d70e8992c3ed0bd9e686b24628321c9bb34bc72c473c19f6d53a6b54c887747bad3b3b5e7f88eefc3d0fafc7a08db4a06cf88ae8b9727735b6626b8 SHA512 97e32218968d27d00ee9525dc3ceddc1d70f94f7bdd361d1b95ec836d7e391cb68536385f8df7259572c9dcc4e574c4a72643f64fbcfb4336578336c33b05619
+EBUILD wayfire-plugins-extra-0.7.5.ebuild 773 BLAKE2B dceb44cffc2fc78abbdb8bfdf348f5219b9fe52d57ab2f202ae7b6513dab7bf35bb9ed84a2595a2e384be2312d0d8ce9fbfe04e95f6c9a49ee97d306986e95f5 SHA512 ca35dac368bdfebb4d87924d9c90cf2899597f7e6e14870c6441115ef603505db8280285d3ee8c8ea3273d01fbc18a5c1ace60fe31627f6e7b2407d56056b920
+EBUILD wayfire-plugins-extra-9999.ebuild 738 BLAKE2B 6686c04e8b8b03f318d73be5143c9bbf9e5a324e10e18c9cc74d211696e294241c416abafded760cdb9e34974c63f57d2534d3c549b70e0ca062750881f26ca4 SHA512 94ef764336abfaa7baee7632fcd06690af2c356a8740a3e81392dd52d0859a493c384c82649f91081854604f37fed7375222f21ed63d8c7c6d1dde0d9df78962
MISC metadata.xml 175 BLAKE2B 4ab58afd88032bf1566270b8294b9e73a1f428b9d5eba0ce122d5b9ce7b23df157f4581232e54659a6e12699af37ca24a639d20f009ca64506692930cfec6160 SHA512 ec5bffe4b7e2473390477784440903946ad4012afbe5a7d651c454b665c95e68d142eaccb464d7181b1c27c22347dc831da35c54019421dbd2ca1ad17744e18d
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild
new file mode 100644
index 000000000000..b9222da14f98
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.7.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="extra plugins for wayfire"
+HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-cpp/glibmm:2
+ x11-libs/pixman
+ gnome-base/librsvg
+ >=gui-libs/wlroots-0.16.0:0/16
+ <gui-libs/wlroots-0.17.0:=
+ >=gui-wm/wayfire-0.7.5
+ x11-libs/cairo
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
index 2558b0e79566..e1eb8908ec68 100644
--- a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson
@@ -21,9 +21,12 @@ SLOT="0"
DEPEND="
dev-cpp/glibmm:2
+ x11-libs/pixman
+ gnome-base/librsvg
~gui-libs/wlroots-9999:=
~gui-wm/wayfire-9999
x11-libs/cairo
+ x11-libs/pixman
"
RDEPEND="${DEPEND}"