summaryrefslogtreecommitdiff
path: root/gui-libs/vte
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 21:37:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 21:37:49 +0100
commit50c291a3ace58006f8fa9cf44a36f6e42bff2b54 (patch)
tree6d245677a5bb2d38b74c141346e35465540e9b7f /gui-libs/vte
parent53623081143d09702d8f3d7224e9da8c5f681c3b (diff)
gentoo auto-resync : 05:06:2023 - 21:37:49
Diffstat (limited to 'gui-libs/vte')
-rw-r--r--gui-libs/vte/Manifest2
-rw-r--r--gui-libs/vte/vte-0.72.2.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/gui-libs/vte/Manifest b/gui-libs/vte/Manifest
index 1904d13a97ba..ec029503d31b 100644
--- a/gui-libs/vte/Manifest
+++ b/gui-libs/vte/Manifest
@@ -1,5 +1,7 @@
AUX vte-0.66.2-musl-W_EXITCODE.patch 779 BLAKE2B c35f3cd21e59b9693d75b00232ef8b2d95448f4ff7031142050e9286ff854a19095bb56cec471d50585302ac08ca7a1d40ad068c013d8af142b0165d4c8d2112 SHA512 a3dd31fb4fcc9c2e725cfd64bbc63def63c1c1a85b6896b4a82083d6ff985df885c3a587e8c3c001de2acae476cb950f05a1e31b33bb263ba4895d25fa1e275b
DIST vte-0.70.0-command-notify.patch.xz 9040 BLAKE2B 108dd05d00409af90b1fd3e9b5c3b0e5586ac80204cef8840fda935204cbc480fec1193e2a0a2782f98e2b094c3caebbfe61cf18631b16921df05cf3808afd22 SHA512 92123e7f5cb6ef876f2b2b108dbef59bce212efebd64cd790d49d9ee3215344acd848eec5d326fe2c3bd236846ed3b896148024390093491b2f6e2f7c46e2bd1
DIST vte-0.72.1.tar.bz2 504271 BLAKE2B 8ab39ab8d491757ab9402ad4bfc10ca733427d2efe895204c0db580e44107a9ab005c29ce2e6934ae27e8da7c27e39d1173fe787ddb8569938a29697eed2e2e1 SHA512 a5655d2d2602183cbda1050003d7cf883e427c8e00976af4ee2685f43530d87169e31a3b9597133d14dffdc95f20f9ca1488186d8463997a2672510f5a95d145
+DIST vte-0.72.2.tar.bz2 503986 BLAKE2B dbd99a1288176482ebe2cee25a1ae508694a8b47739e9c93aa8f752bf50a1f7a6efd0944430550a73224ac92248e2c4738c51eec66a643efc03616dfa7c4b110 SHA512 0510677d67474fb04c69df0038b042d379ac8e1e89b77961e403b854e4a26b2063e93bcffd75ef0a0a324df077cf2f0a4ce51afa0ad0b1e66f707393590af274
EBUILD vte-0.72.1.ebuild 3194 BLAKE2B 6a4746c749a0d51f4faa4ab15f761c5b95a1513eba19b8906669a287b21ef7c72718b935be693987b0dca527f00d9274ab4246903248d64643ce2dfade269f49 SHA512 67be6ffefab986f03ca6ec60fff34744181e813acabeeeefa951922bfbaa8ed30f97c13ab06176758b76b2a258d7defbbdbf85f372e516015ef73b5c57e15b91
+EBUILD vte-0.72.2.ebuild 3201 BLAKE2B c747d0ec8f9578bcda891981652798a2f15a83ffb4fa9e2106e2efd583adab44ba1ef744bebbfe296a33680c58f1b6c2c9d6430f24d25f82dee82717b2749c2a SHA512 778fd60493dfdf33f3f7a441d616b6ada66a2c4151edd3a455750868e2a462cb916540e4747e330a0ab9cfc4154eb52111b38b044c78d26d9859a1b3b1c4a8d1
MISC metadata.xml 612 BLAKE2B 3243ec48375bf8e69a367e5d631cf84c0ba60b43d1f4a25c313a407bfb1c9826ddd1cd75784bc302e7d8998d1bedaac9d75c7f329255e605315d9f0bf6154a73 SHA512 0abc6f1deb0a7900b6b35620ad3dfa26a900445526cc6474f974ce5cca2dad65cb3f3c4e3b8a59540821a9922e2cafcc7011d705570e77d2a46c907f3962a73d
diff --git a/gui-libs/vte/vte-0.72.2.ebuild b/gui-libs/vte/vte-0.72.2.ebuild
new file mode 100644
index 000000000000..e415717ff0ab
--- /dev/null
+++ b/gui-libs/vte/vte-0.72.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org meson python-any-r1 vala xdg
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91-gtk4" # vte_api_version + "-gtk4" in meson.build
+IUSE="+crypt debug gtk-doc +icu +introspection systemd +vala vanilla"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-0.70.0-command-notify.patch.xz )"
+
+DEPEND="
+ >=gui-libs/gtk-4.0.1:4[introspection?]
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.60:2
+ crypt? ( >=net-libs/gnutls-3.2.7:0= )
+ icu? ( dev-libs/icu:= )
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21:=
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ x11-libs/pango[introspection?]
+"
+RDEPEND="${DEPEND}
+ ~gui-libs/vte-common-${PV}[systemd?]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gi-docgen )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.66.2-musl-W_EXITCODE.patch
+
+ if ! use vanilla; then
+ # Part of https://src.fedoraproject.org/rpms/vte291/raw/f37/f/vte291-cntnr-precmd-preexec-scroll.patch
+ # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+ eapply "${WORKDIR}"/${PN}-0.70.0-command-notify.patch
+ fi
+
+ # -Ddebugg option enables various debug support via VTE_DEBUG, but also ggdb3; strip the latter
+ sed -e '/ggdb3/d' -i meson.build || die
+ sed -i 's/vte_gettext_domain = vte_api_name/vte_gettext_domain = vte_gtk4_api_name/' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=true
+ $(meson_use debug debugg)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=true
+ $(meson_use crypt gnutls)
+ -Dgtk3=false
+ -Dgtk4=true
+ $(meson_use icu)
+ $(meson_use systemd _systemd)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ # not meson_src_install because this would include einstalldocs, which
+ # would result in file collisions with x11-libs/vte
+ meson_install
+
+ # Remove files that are provided by gui-libs/vte-common
+ rm "${ED}"/usr/libexec/vte-urlencode-cwd || die
+ rm "${ED}"/etc/profile.d/vte.sh || die
+ rm "${ED}"/etc/profile.d/vte.csh || die
+ if use systemd; then
+ rm "${ED}"/usr/lib/systemd/user/vte-spawn-.scope.d/defaults.conf || die
+ fi
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/vte-${SLOT} "${ED}"/usr/share/gtk-doc/ || die
+ fi
+}