summaryrefslogtreecommitdiff
path: root/gui-libs/vte-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-26 21:08:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-26 21:08:42 +0100
commit90e9e4843d7d63c5e7fa1f5d6d6f4cc7350ce77c (patch)
tree16bc65eacafd47e7f03f3a52a344a17ba1f1b316 /gui-libs/vte-common
parent2ad011cd42b40aebf90105be4521fb1727266d1d (diff)
gentoo auto-resync : 26:09:2022 - 21:08:42
Diffstat (limited to 'gui-libs/vte-common')
-rw-r--r--gui-libs/vte-common/Manifest4
-rw-r--r--gui-libs/vte-common/files/vte-common-0.70.0-musl-W_EXITCODE.patch29
-rw-r--r--gui-libs/vte-common/metadata.xml12
-rw-r--r--gui-libs/vte-common/vte-common-0.70.0.ebuild78
4 files changed, 123 insertions, 0 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
new file mode 100644
index 000000000000..22f2e75c9493
--- /dev/null
+++ b/gui-libs/vte-common/Manifest
@@ -0,0 +1,4 @@
+AUX vte-common-0.70.0-musl-W_EXITCODE.patch 779 BLAKE2B c35f3cd21e59b9693d75b00232ef8b2d95448f4ff7031142050e9286ff854a19095bb56cec471d50585302ac08ca7a1d40ad068c013d8af142b0165d4c8d2112 SHA512 a3dd31fb4fcc9c2e725cfd64bbc63def63c1c1a85b6896b4a82083d6ff985df885c3a587e8c3c001de2acae476cb950f05a1e31b33bb263ba4895d25fa1e275b
+DIST vte-0.70.0.tar.bz2 499283 BLAKE2B 694cf4dfee334e9b54bb8e47f862167acbb8ffc7ac8e81889acd4786449cb45944a87a5adaa036f46458c350ca2119bb356e90dfa71f03638c9c2b14d2ccb877 SHA512 362b71296ae39a16b55402f524a39b063f66ae237e6e161ccc89ca2bb1f2a5c43f4d706d9f3bfae12a99fdb81c4e70408c7f3eca2c01316950b0a3a1a1d79423
+EBUILD vte-common-0.70.0.ebuild 1875 BLAKE2B 33d970a32aa2880b787e24e295e55132c6ec47094d418a2c9033709507561b6e69d603d744b60bd8b821e1337c8f0e4e89a5b9251f86fadda88dbc53dfee08e8 SHA512 738d0259ebd7b68d15c682159f3cd40267e593ce9728474b8e4c5d6031e85b18f7f7508c2debdafe80948cd9dd05b44441a8ceaae715b676fc649a598ce23439
+MISC metadata.xml 433 BLAKE2B 2c71854e6417f0cb37252264beb583f6d0beaada3da3f8ca80c94a0e244065113827f2acf0655632387e2d1689e85dc91ce3be9989b68f0e61bc44b39d898cd8 SHA512 88d6c25bc0de5ef7642320fadb60922d9dfe745e77a99d7aa51d6d55c5355d3f20f65ec29ce951474ccfa158d4c1a81613c24ab274b4cff1b8908e9979c0108e
diff --git a/gui-libs/vte-common/files/vte-common-0.70.0-musl-W_EXITCODE.patch b/gui-libs/vte-common/files/vte-common-0.70.0-musl-W_EXITCODE.patch
new file mode 100644
index 000000000000..b629613feaf6
--- /dev/null
+++ b/gui-libs/vte-common/files/vte-common-0.70.0-musl-W_EXITCODE.patch
@@ -0,0 +1,29 @@
+https://gitlab.gnome.org/GNOME/vte/-/issues/72
+https://bugs.gentoo.org/835489
+https://bugs.gentoo/org/554416
+
+From 1c1de9e9119cf1e0ef45a594ca9bbf306d2209cb Mon Sep 17 00:00:00 2001
+From:
+Date: Fri, 12 Mar 2021 08:41:13 -0600
+Subject: [PATCH] Expanded non-standard W_EXITCODE macro for Musl compatibility
+
+--- a/src/widget.cc
++++ b/src/widget.cc
+@@ -20,8 +20,6 @@
+
+ #include "widget.hh"
+
+-#include <sys/wait.h> // for W_EXITCODE
+-
+ #include <exception>
+ #include <new>
+ #include <string>
+@@ -235,7 +233,7 @@ void
+ Widget::dispose() noexcept
+ {
+ if (m_terminal->terminate_child()) {
+- int status = W_EXITCODE(0, SIGKILL);
++ int status = (0) << 8 | (SIGKILL); // W_EXITCODE(ret, sig)
+ emit_child_exited(status);
+ }
+ }
diff --git a/gui-libs/vte-common/metadata.xml b/gui-libs/vte-common/metadata.xml
new file mode 100644
index 000000000000..27f2ae98ad3b
--- /dev/null
+++ b/gui-libs/vte-common/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="systemd">Support moving terminal child processes to their own systemd user scopes
+ to avoid terminal getting killed due to child causing OOM</flag>
+ </use>
+</pkgmetadata>
diff --git a/gui-libs/vte-common/vte-common-0.70.0.ebuild b/gui-libs/vte-common/vte-common-0.70.0.ebuild
new file mode 100644
index 000000000000..23bef45e9c29
--- /dev/null
+++ b/gui-libs/vte-common/vte-common-0.70.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org meson python-any-r1
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE https://gitlab.gnome.org/GNOME/vte"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91" # vte_api_version in meson.build
+IUSE="systemd"
+KEYWORDS="~amd64"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/vte/-/archive/${PV}/vte-${PV}.tar.bz2"
+
+DEPEND="
+ || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ x11-libs/pango
+"
+RDEPEND="
+ !<x11-libs/vte-0.70.0
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/vte-0.70.0"
+
+src_prepare() {
+ default
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=false
+ -Ddebugg=false
+ -Ddocs=false
+ -Dgir=false
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=false
+ -Dgnutls=false
+ -Dgtk3=false
+ -Dgtk4=false
+ -Dicu=false
+ $(meson_use systemd _systemd)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ exeinto /usr/libexec/
+ doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
+ insinto /etc/profile.d/
+ newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
+ newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
+ if use systemd; then
+ insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
+ newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
+ fi
+ einstalldocs
+}