summaryrefslogtreecommitdiff
path: root/gui-libs/libhandy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /gui-libs/libhandy
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'gui-libs/libhandy')
-rw-r--r--gui-libs/libhandy/Manifest3
-rw-r--r--gui-libs/libhandy/libhandy-0.0.9.ebuild61
-rw-r--r--gui-libs/libhandy/metadata.xml13
3 files changed, 77 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
new file mode 100644
index 000000000000..d8de0083499f
--- /dev/null
+++ b/gui-libs/libhandy/Manifest
@@ -0,0 +1,3 @@
+DIST libhandy-v0.0.9.tar.bz2 110100 BLAKE2B c1abf60b37d76a0b2f0ed82152decc9a87c9feff664af8df91ede192018a70003ac7ff3c1307668e7196089f59bb5dc21d1449ccc1deb3e2e362f32ff8f9f30b SHA512 d3256c2ff49a7fd0ccfec14ba3e34ed51577841c1670902d25f2a0166e63820428e689c722dddbccf787e1380c7f9a8ddc5b9042a1632b688b151ecce0f6d262
+EBUILD libhandy-0.0.9.ebuild 1488 BLAKE2B 6884b6ab7e679f9e377a07fade5656f0a6eff48c571c7e7a8705a745569bd1db9f04611567bfd92dcd4fb2fd47274671c6b3e1a4bf16b00dd3741c4d13f8e4ec SHA512 2316886ff4e88d850e1f2692536e25605e739a3347905ed010a17fbf06ea2e575184c5955f12ea5a931af3278616f78c897292efcbe9d5d554b1d1f4233c8afd
+MISC metadata.xml 474 BLAKE2B b8fba1ac64b79eaadbd70099133bc57a69be78738b9da3742ac9381286f62e5198b5b6dc5bf51dd5a11e0ea06819d3ccc00157f7f69939f18db18016db47705a SHA512 d9c79fbc1e8549dcdf6e42263040844efd729440d725df7c8f06bdf5e6c8da0de8f24186c94a2444e03f4396aaa1e4043d1893996770cfa2e5ea9f1b0ca71b4a
diff --git a/gui-libs/libhandy/libhandy-0.0.9.ebuild b/gui-libs/libhandy/libhandy-0.0.9.ebuild
new file mode 100644
index 000000000000..06eafda4c3dc
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-0.0.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg vala virtualx
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="Library with GTK widgets for mobile phones"
+HOMEPAGE="https://source.puri.sm/Librem5/libhandy/"
+SRC_URI="https://source.puri.sm/Librem5/libhandy/-/archive/v${PV}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.0/0" # It may or may not break ABI in future versions at this point; if new
+# SLOT happens, it'll likely file conflict on gtk-doc and glade library and catalog
+KEYWORDS="~amd64"
+
+IUSE="examples glade gtk-doc +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ -Dstatic=false
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
diff --git a/gui-libs/libhandy/metadata.xml b/gui-libs/libhandy/metadata.xml
new file mode 100644
index 000000000000..65bbdf40f15f
--- /dev/null
+++ b/gui-libs/libhandy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="glade">Install module and catalog for <pkg>dev-util/glade</pkg></flag>
+ </use>
+ <longdescription>libhandy is a collection of GTK+ widgets for applications
+ targeting mobile phones.</longdescription>
+</pkgmetadata>