summaryrefslogtreecommitdiff
path: root/gui-libs/libhandy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-09 23:33:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-09 23:33:53 +0000
commit304c1973bececee173a9d6235a2c364466d309e1 (patch)
tree11acd7542e4ef6dd961bb3c64dae01ba417212e6 /gui-libs/libhandy
parent4d643b662f77ef9cc872089cad15cf5e7e1f70f2 (diff)
gentoo auto-resync : 09:02:2024 - 23:33:52
Diffstat (limited to 'gui-libs/libhandy')
-rw-r--r--gui-libs/libhandy/Manifest2
-rw-r--r--gui-libs/libhandy/libhandy-1.8.3.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index d43c8ba32164..1636448547cb 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1,3 +1,5 @@
DIST libhandy-1.8.2.tar.xz 1778096 BLAKE2B 83b8316b22e7bd37436d5fdad0bd270dd5d64862bca97d358b0c2a1c6b7b0e18e0f472ce453719dfde982a427fd7c0c523b042d7721415602d3e7b9c57399509 SHA512 ec48c66a95b1e9158d3e072e1cfab6d538a9235966c790f1e4d4f2ec40a251c8818f505d031285a53ce855da92b7919d3a26aca4160d93241925da1e8cf4b748
+DIST libhandy-1.8.3.tar.xz 1791428 BLAKE2B 4e90929e62a197b3dbc8a2565198486d5acd231768afeece617b95c7bf8f689afba01c8bd90312cb41a1c388627b64a31286a706b8422485012754a955925957 SHA512 1e0ae363d2a4993c9667243715256b27cb0ecb898fa8f4ea1a914fbeb36c0a9c26447f8f13f92f5a855e45ada49f732adeb30b88d81f3ee5f984bca48db3ae65
EBUILD libhandy-1.8.2.ebuild 1331 BLAKE2B d9d13cdab806f3613f3cec8dfcd9c0bad45d0b701a3a93481a9f8ad45abcf540a63350a1e43d0349218c9c35cbcf9a75b92cb1d06b2335ba398529adb32a7ac7 SHA512 1cf3cbe52c7263e1f7c2512bc10a607c1551f05b03953c3a87dab1fac5116ff1d6a4d2f830e3226374b63bf0095db38f7ed801ea4969e87aca1717dfbd166b04
+EBUILD libhandy-1.8.3.ebuild 1336 BLAKE2B 96fea08e4b01376672b8581977dac247fd0295ac238be581b21dc99111226e925e060c0171b3025a4db36a294d40eac8f77e365352ba929ee29253e59d723cda SHA512 1596453e527e5df687b6d9e0c8d57475af3727748823d78e2dedeb57150d88e86be0efb2ed52f55242171eb14397d97c6037573be5b4549ccf4a183f6b377906
MISC metadata.xml 453 BLAKE2B 3b7a719256d86a2cb3411691777d24bb9638760fc17312e299b9895c8a75e088a438db4a16cd81846564b655ea27bdd1f27b3220571b71a264e5171f22ebdac7 SHA512 8d2ffbe79d880deef5f132e3a10ecfa4a044553a075a63904b4938b15bb47104d2ea731bdc5472bfcb816c4fcca83453b81ec1b3dff29f3ce0968a79d22c5106
diff --git a/gui-libs/libhandy/libhandy-1.8.3.ebuild b/gui-libs/libhandy/libhandy-1.8.3.ebuild
new file mode 100644
index 000000000000..42450f370ce7
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.8.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}