summaryrefslogtreecommitdiff
path: root/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild')
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..9c563ef3fd23
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="examples gtk-doc"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3[introspection,wayland]
+ >=dev-libs/wayland-1.10.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ )
+ meson_src_configure
+}