summaryrefslogtreecommitdiff
path: root/gui-apps/wofi/wofi-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
commit05a3b7c2189f095dfc46fbb03d4b3e801d3dc13a (patch)
tree46ab17fba7d43e3132d97ee97ebd604dea996018 /gui-apps/wofi/wofi-9999.ebuild
parentc73b611d606bc14760bad8592f5bfec28c9b1079 (diff)
gentoo auto-resync : 14:12:2022 - 09:29:38
Diffstat (limited to 'gui-apps/wofi/wofi-9999.ebuild')
-rw-r--r--gui-apps/wofi/wofi-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/gui-apps/wofi/wofi-9999.ebuild b/gui-apps/wofi/wofi-9999.ebuild
new file mode 100644
index 000000000000..70187e690c67
--- /dev/null
+++ b/gui-apps/wofi/wofi-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit mercurial
+ EHG_REPO_URI="https://hg.sr.ht/~scoopta/${PN}"
+else
+ SRC_URI="https://hg.sr.ht/~scoopta/wofi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Wofi is a launcher/menu program for wlroots based wayland compositors like sway"
+HOMEPAGE="https://hg.sr.ht/~scoopta/wofi"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-libs/wayland
+ x11-libs/gtk+:3[wayland(-)]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3-no-hg-identify.patch" )