summaryrefslogtreecommitdiff
path: root/gui-apps/wl-clipboard/wl-clipboard-2.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
commit20325cfc3bd40d48d3c7034afaac4f5193d9c704 (patch)
treeb8e6ff7fc02271595e20f956b32cef56c41dafca /gui-apps/wl-clipboard/wl-clipboard-2.2.1.ebuild
parent14a6858a7d8bc085420a1430b3a3f67885019f27 (diff)
gentoo auto-resync : 29:08:2023 - 10:04:54
Diffstat (limited to 'gui-apps/wl-clipboard/wl-clipboard-2.2.1.ebuild')
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-2.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/gui-apps/wl-clipboard/wl-clipboard-2.2.1.ebuild b/gui-apps/wl-clipboard/wl-clipboard-2.2.1.ebuild
new file mode 100644
index 000000000000..0418c679db5e
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-2.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ dev-libs/wayland-protocols"