summaryrefslogtreecommitdiff
path: root/gui-apps/wl-clipboard/wl-clipboard-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /gui-apps/wl-clipboard/wl-clipboard-2.1.0.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'gui-apps/wl-clipboard/wl-clipboard-2.1.0.ebuild')
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-2.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/gui-apps/wl-clipboard/wl-clipboard-2.1.0.ebuild b/gui-apps/wl-clipboard/wl-clipboard-2.1.0.ebuild
new file mode 100644
index 000000000000..57b5f83eaace
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-2.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""