summaryrefslogtreecommitdiff
path: root/gui-apps/waybar/waybar-0.9.17-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 05:49:50 +0100
commit1ac83daac7198a5717483e1cfab669ba4f12debe (patch)
treefb9c448591e3f43e411800a609df633313aab78f /gui-apps/waybar/waybar-0.9.17-r1.ebuild
parentfddb33ccaadabe03f5571606f796b45965b38e9c (diff)
gentoo auto-resync : 16:04:2023 - 05:49:50
Diffstat (limited to 'gui-apps/waybar/waybar-0.9.17-r1.ebuild')
-rw-r--r--gui-apps/waybar/waybar-0.9.17-r1.ebuild102
1 files changed, 0 insertions, 102 deletions
diff --git a/gui-apps/waybar/waybar-0.9.17-r1.ebuild b/gui-apps/waybar/waybar-0.9.17-r1.ebuild
deleted file mode 100644
index 9ee87022a46b..000000000000
--- a/gui-apps/waybar/waybar-0.9.17-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson
-
-DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors"
-HOMEPAGE="https://github.com/Alexays/Waybar"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
-else
- SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN^}-${PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="evdev experimental jack libinput logind mpd mpris network +popups pipewire pulseaudio sndio test tray +udev upower wifi"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=app-text/scdoc-1.9.2
- dev-util/gdbus-codegen
- virtual/pkgconfig
-"
-RDEPEND="
- dev-cpp/cairomm:0
- dev-cpp/glibmm:2
- dev-cpp/gtkmm:3.0
- dev-libs/glib:2
- dev-libs/jsoncpp:=
- dev-libs/libinput:=
- dev-libs/libsigc++:2
- >=dev-libs/libfmt-7.0.0:=
- >=dev-libs/spdlog-1.8.5:=
- dev-libs/date:=
- dev-libs/wayland
- gui-libs/wlroots:=
- x11-libs/gtk+:3[wayland]
- x11-libs/libxkbcommon
- evdev? ( dev-libs/libevdev:= )
- jack? ( virtual/jack )
- libinput? ( dev-libs/libinput:= )
- logind? (
- || ( sys-apps/systemd
- sys-auth/elogind )
- )
- mpd? ( media-libs/libmpdclient )
- mpris? ( >=media-sound/playerctl-2 )
- network? ( dev-libs/libnl:3 )
- popups? ( gui-libs/gtk-layer-shell )
- pipewire? ( media-video/wireplumber:0/0.4 )
- pulseaudio? ( media-sound/pulseaudio[daemon] )
- sndio? ( media-sound/sndio:= )
- tray? (
- dev-libs/libdbusmenu[gtk3]
- dev-libs/libappindicator
- )
- udev? ( virtual/libudev:= )
- upower? ( sys-power/upower )
- wifi? ( sys-apps/util-linux )
-"
-DEPEND="${RDEPEND}
- dev-libs/wayland-protocols
- test? ( dev-cpp/catch:0 )
-"
-
-PATCHES=(
- "${FILESDIR}/waybar-0.9.17-wireplumber.patch"
- "${FILESDIR}/waybar-0.9.17-gcc13.patch"
- "${FILESDIR}/systemd-0.9.17.patch"
-)
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=enabled
- -Dsystemd=enabled
- $(meson_feature evdev libevdev)
- $(meson_feature jack)
- $(meson_feature libinput)
- $(meson_feature logind)
- $(meson_feature mpd)
- $(meson_feature mpris)
- $(meson_feature network libnl)
- $(meson_feature popups gtk-layer-shell)
- $(meson_feature pulseaudio)
- $(meson_feature pipewire wireplumber)
- $(meson_feature sndio)
- $(meson_feature test tests)
- $(meson_feature tray dbusmenu-gtk)
- $(meson_feature udev libudev)
- $(meson_feature upower upower_glib)
- $(meson_feature wifi rfkill)
- $(meson_use experimental)
- )
- meson_src_configure
-}