summaryrefslogtreecommitdiff
path: root/gui-apps/swayidle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /gui-apps/swayidle
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'gui-apps/swayidle')
-rw-r--r--gui-apps/swayidle/Manifest4
-rw-r--r--gui-apps/swayidle/metadata.xml30
-rw-r--r--gui-apps/swayidle/swayidle-1.2.ebuild57
-rw-r--r--gui-apps/swayidle/swayidle-9999.ebuild57
4 files changed, 148 insertions, 0 deletions
diff --git a/gui-apps/swayidle/Manifest b/gui-apps/swayidle/Manifest
new file mode 100644
index 000000000000..c5fac66c7f85
--- /dev/null
+++ b/gui-apps/swayidle/Manifest
@@ -0,0 +1,4 @@
+DIST swayidle-1.2.tar.gz 9136 BLAKE2B e88eec89007deed59df30f3f89111352b8a1ed464141783cb25b0d0a484e8ea4cfd611f1bd80d9420368d7912979eb0536a6aa583d24504d32bac797a898dba5 SHA512 2539e80a45163bb3e76f7b41f6fd6a1d73d194b7e466f63178b5087d05470fceafba38a26d592a534a01b992a2c0cf0f8fb83805cdf41ee956fea5136cc8fe89
+EBUILD swayidle-1.2.ebuild 1323 BLAKE2B f679d7519e3618808690658d57dc38982d78ee98ce05c218e4775cf9cfecfeef733396111fdf98b75299db13e437f94d98b5cc17ef64a138900c99a96a911333 SHA512 497296c3a41fc8337bce8f8aa29822f3ca7b1dc5b5dd774204a648331fd60ebc80e6d44554562fa65de4c5f4b22f087594c14677b1ceb5ad9f33f729c6ffda18
+EBUILD swayidle-9999.ebuild 1323 BLAKE2B f679d7519e3618808690658d57dc38982d78ee98ce05c218e4775cf9cfecfeef733396111fdf98b75299db13e437f94d98b5cc17ef64a138900c99a96a911333 SHA512 497296c3a41fc8337bce8f8aa29822f3ca7b1dc5b5dd774204a648331fd60ebc80e6d44554562fa65de4c5f4b22f087594c14677b1ceb5ad9f33f729c6ffda18
+MISC metadata.xml 1067 BLAKE2B 059ead0c34aebcaa6f8ebd10db8b9b0aaf2df66f84a6ae10d16f3a32d680426aa4733c0788dfe61532bb90d3b92f4bb451e7fd1be822c6866205575fd3c4861a SHA512 99a60f4bcfb76aa7d2a6d4d2a7a6879d9f0ac17f0be3e37d59bef4a4b158b9e685dd5932a02e650b96756dc7f6cba2aac9b1eee95c6d56f4429c23e32a101ad4
diff --git a/gui-apps/swayidle/metadata.xml b/gui-apps/swayidle/metadata.xml
new file mode 100644
index 000000000000..880f87d424ec
--- /dev/null
+++ b/gui-apps/swayidle/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>speedjack95@gmail.com</email>
+ <name>Niccolò Scatena</name>
+ </maintainer>
+ <longdescription lang="en">
+ Sway's idle management daemon, compatible with any Wayland compositor
+ which implements the KDE idle protocol.
+ </longdescription>
+ <use>
+ <flag name="elogind">Enable support for rootless session via elogind</flag>
+ <flag name="fish-completion">Enable fish completion support</flag>
+ <flag name="man">Build and install man pages</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">swaywm/swayidle</remote-id>
+ <maintainer status="active">
+ <email>sir@cmpwn.com</email>
+ <name>Drew DeVault</name>
+ </maintainer>
+ <bugs-to>https://github.com/swaywm/swayidle/issues</bugs-to>
+ <changelog>https://github.com/swaywm/swayidle/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/swayidle/swayidle-1.2.ebuild b/gui-apps/swayidle/swayidle-1.2.ebuild
new file mode 100644
index 000000000000..4ee88f1b8179
--- /dev/null
+++ b/gui-apps/swayidle/swayidle-1.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Idle management daemon for Wayland"
+HOMEPAGE="https://github.com/swaywm/swayidle"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind fish-completion +man systemd zsh-completion"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ dev-libs/wayland
+ elogind? ( >=sys-auth/elogind-237[policykit] )
+ systemd? ( >=sys-apps/systemd-237[policykit] )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=gui-wm/sway-1.0_beta1
+ !~gui-wm/sway-1.0_beta2[swayidle]
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ $(meson_use fish-completion fish-completions)
+ $(meson_use zsh-completion zsh-completions)
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}
diff --git a/gui-apps/swayidle/swayidle-9999.ebuild b/gui-apps/swayidle/swayidle-9999.ebuild
new file mode 100644
index 000000000000..4ee88f1b8179
--- /dev/null
+++ b/gui-apps/swayidle/swayidle-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Idle management daemon for Wayland"
+HOMEPAGE="https://github.com/swaywm/swayidle"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind fish-completion +man systemd zsh-completion"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ dev-libs/wayland
+ elogind? ( >=sys-auth/elogind-237[policykit] )
+ systemd? ( >=sys-apps/systemd-237[policykit] )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=gui-wm/sway-1.0_beta1
+ !~gui-wm/sway-1.0_beta2[swayidle]
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ $(meson_use fish-completion fish-completions)
+ $(meson_use zsh-completion zsh-completions)
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}