summaryrefslogtreecommitdiff
path: root/gui-apps/mako/mako-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /gui-apps/mako/mako-1.7.1.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'gui-apps/mako/mako-1.7.1.ebuild')
-rw-r--r--gui-apps/mako/mako-1.7.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/gui-apps/mako/mako-1.7.1.ebuild b/gui-apps/mako/mako-1.7.1.ebuild
new file mode 100644
index 000000000000..fdd5238afe72
--- /dev/null
+++ b/gui-apps/mako/mako-1.7.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway"
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind +icons systemd"
+
+DEPEND="
+ dev-libs/wayland
+ dev-util/wayland-scanner
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ sys-libs/basu
+ )
+ sys-apps/dbus
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-libs/wayland-protocols-1.21
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ )
+
+ if use systemd ; then
+ emesonargs+=( -Dsd-bus-provider=libsystemd )
+ elif use elogind ; then
+ emesonargs+=( -Dsd-bus-provider=libelogind )
+ else
+ emesonargs+=( -Dsd-bus-provider=basu )
+ fi
+
+ meson_src_configure
+}