summaryrefslogtreecommitdiff
path: root/gui-apps/kanshi/kanshi-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-16 20:31:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-16 20:31:05 +0100
commitae99f3df3fb5c7ebb085d4a198c1854a4c9a1bee (patch)
tree63845e7d405c04516103b1cee33911cea9a63b0e /gui-apps/kanshi/kanshi-1.2.0.ebuild
parent2cb26483945211e812d7a0351ae472a676cd9592 (diff)
gentoo auto-resync : 16:08:2022 - 20:31:05
Diffstat (limited to 'gui-apps/kanshi/kanshi-1.2.0.ebuild')
-rw-r--r--gui-apps/kanshi/kanshi-1.2.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gui-apps/kanshi/kanshi-1.2.0.ebuild b/gui-apps/kanshi/kanshi-1.2.0.ebuild
new file mode 100644
index 000000000000..b415cae3b1ac
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-1.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://wayland.emersion.fr/kanshi/ https://sr.ht/~emersion/kanshi/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/kanshi"
+else
+ SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+RDEPEND="
+ dev-libs/wayland
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ )
+ meson_src_configure
+}