summaryrefslogtreecommitdiff
path: root/gui-apps/grim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 09:51:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 09:51:58 +0000
commitbaeb826318951e5c82b18c1e9ee120ac5dcf0b94 (patch)
tree7154de118466f928d847a0659795c3f84c116096 /gui-apps/grim
parent1e17db840dfd2f8b2b43a0a385c106812ebcfea9 (diff)
gentoo auto-resync : 25:02:2023 - 09:51:58
Diffstat (limited to 'gui-apps/grim')
-rw-r--r--gui-apps/grim/Manifest3
-rw-r--r--gui-apps/grim/grim-1.4.0-r2.ebuild50
-rw-r--r--gui-apps/grim/grim-9999.ebuild9
3 files changed, 57 insertions, 5 deletions
diff --git a/gui-apps/grim/Manifest b/gui-apps/grim/Manifest
index ded729df97e6..15233267466f 100644
--- a/gui-apps/grim/Manifest
+++ b/gui-apps/grim/Manifest
@@ -1,4 +1,5 @@
DIST grim-1.4.0.tar.gz 18287 BLAKE2B 72606de01624c98876fe1018877a3cf0b25b44ac4bd6a053f82c40ad1ea2c6c0e510cbb6a0bce988f14607ea162dda1d8350b9f30b0f2b9acd8f8e20ba50bc99 SHA512 d0b33528a00528b3ef7488a0984cde5034de4f5a211eb5c8d3299aea356d9348c5d02d08171802bc0315afb19d2446f5f132ea9dca0579ace803b7d5d90a89cc
EBUILD grim-1.4.0-r1.ebuild 1076 BLAKE2B 95b40a13619c6bb236d759aa892b45390fb795f9f91fa75123436d946b8253e1ea3d568e84374608e73f5b465d12aa645ccd40c75a1961b00f3fd6d56581cf53 SHA512 e01b9b4535b51cc2c8cf355d2ee3ecffd9209604e04fbb8e2f582e766e6b52dc0b4587e2fa687c2709a9734e1a040e3a0f93493143f890e8aabddc77c8bc15c8
-EBUILD grim-9999.ebuild 1067 BLAKE2B 25c24e3f3b45b085d0c0f6b0eaafa50feb11bfedd992a4b6d167bebc41082b6f94115459e660b6ec72d09aa5c12f52eb2bfa60781d149871c1590600ed1c36d5 SHA512 765dede84a5babe46c2e6f30efe85ae628af07a3fc121db324a487e7dd8374b9d096f92e8396b0af1a53662a9f331c28887378c2ea26f69c30da592b098ac074
+EBUILD grim-1.4.0-r2.ebuild 1069 BLAKE2B 84a65a64034b7014018bf0110c9443ef61003ddf5aa3d49f8e21e720a7bb0fcee64f5d9c837c388d15ad4b55520461da95d1a01f2d2690f640733478b1f7cfd4 SHA512 676cb862693ced858396f984be44af0af8454ff556727db2a08c902e73aa9ca2fcf670cc618d7686a23447c7230fe61db31e618b17776284fb3ed0d09811b519
+EBUILD grim-9999.ebuild 1069 BLAKE2B 84a65a64034b7014018bf0110c9443ef61003ddf5aa3d49f8e21e720a7bb0fcee64f5d9c837c388d15ad4b55520461da95d1a01f2d2690f640733478b1f7cfd4 SHA512 676cb862693ced858396f984be44af0af8454ff556727db2a08c902e73aa9ca2fcf670cc618d7686a23447c7230fe61db31e618b17776284fb3ed0d09811b519
MISC metadata.xml 524 BLAKE2B c2366f76a73d9dda9a1316f946507b249c69aa8a4253c2d8e1dbc803734472e71ffbba1300b750f53e8d5bf1d4be588ba4072e72411c585a60e8dfdf21e88735 SHA512 a13136352443f4599ee0be777da4fffa1c2ef09593a0bde436b1eae3f12f135a78605152c7d5f9f58cd798608251debb306e7f1147cdeb4facdb5c8407a39ba8
diff --git a/gui-apps/grim/grim-1.4.0-r2.ebuild b/gui-apps/grim/grim-1.4.0-r2.ebuild
new file mode 100644
index 000000000000..055ea22ded2b
--- /dev/null
+++ b/gui-apps/grim/grim-1.4.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 meson
+
+DESCRIPTION="Grab images from a Wayland compositor"
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+RDEPEND="
+ dev-libs/wayland
+ media-libs/libpng
+ x11-libs/pixman
+ jpeg? ( media-libs/libjpeg-turbo )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/wayland-protocols-1.14
+"
+BDEPEND="man? ( app-text/scdoc )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dbash-completions=false"
+ "-Dfish-completions=false"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ newbashcomp contrib/completions/bash/grim.bash grim
+ insinto /usr/share/fish/vendor_completions.d/
+ doins contrib/completions/grim.fish
+}
diff --git a/gui-apps/grim/grim-9999.ebuild b/gui-apps/grim/grim-9999.ebuild
index d4e0f640652a..055ea22ded2b 100644
--- a/gui-apps/grim/grim-9999.ebuild
+++ b/gui-apps/grim/grim-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,14 +20,15 @@ LICENSE="MIT"
SLOT="0"
IUSE="+man jpeg"
-DEPEND="
+RDEPEND="
dev-libs/wayland
- >=dev-libs/wayland-protocols-1.14
media-libs/libpng
x11-libs/pixman
jpeg? ( media-libs/libjpeg-turbo )
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ >=dev-libs/wayland-protocols-1.14
+"
BDEPEND="man? ( app-text/scdoc )"
src_configure() {