summaryrefslogtreecommitdiff
path: root/gui-apps/gnome-console/gnome-console-43.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 07:29:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 07:29:33 +0100
commit4cc852b4016d8aa1fa4d7a8b3911bebe1ed1da50 (patch)
tree63c3a168bb59a510954fae0dc96a9f4658d22b31 /gui-apps/gnome-console/gnome-console-43.0.ebuild
parentad75ca50360f9590325f0f709c091832b70eab1d (diff)
gentoo auto-resync : 08:10:2022 - 07:29:32
Diffstat (limited to 'gui-apps/gnome-console/gnome-console-43.0.ebuild')
-rw-r--r--gui-apps/gnome-console/gnome-console-43.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gui-apps/gnome-console/gnome-console-43.0.ebuild b/gui-apps/gnome-console/gnome-console-43.0.ebuild
new file mode 100644
index 000000000000..c4b376a3f0ff
--- /dev/null
+++ b/gui-apps/gnome-console/gnome-console-43.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple user-friendly terminal emulator for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/console"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.72:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/libadwaita-1.2:1
+ >=gui-libs/vte-0.70.0:2.91-gtk4
+ gnome-base/libgtop:2=
+ >=dev-libs/libpcre2-10.32:0=
+ gnome-base/gsettings-desktop-schemas
+
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local emesonargs=(
+ -Ddevel=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}