summaryrefslogtreecommitdiff
path: root/gnustep-libs/performance/performance-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnustep-libs/performance/performance-0.5.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnustep-libs/performance/performance-0.5.0.ebuild')
-rw-r--r--gnustep-libs/performance/performance-0.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnustep-libs/performance/performance-0.5.0.ebuild b/gnustep-libs/performance/performance-0.5.0.ebuild
new file mode 100644
index 000000000000..5f6bcc8b2665
--- /dev/null
+++ b/gnustep-libs/performance/performance-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnustep-2
+
+MY_P=${P/p/P}
+DESCRIPTION="Help improve the performance of GNUstep applications"
+HOMEPAGE="http://wiki.gnustep.org/index.php/Performance"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if ! use doc; then
+ # Remove doc target
+ sed -i -e '/documentation\.make/d' GNUmakefile \
+ || die "doc sed failed"
+ fi
+
+ default
+}