summaryrefslogtreecommitdiff
path: root/gnustep-base/libobjc2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-27 01:01:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-27 01:01:27 +0000
commit0b8b325c6d134a9f66de2ba751280e6480e609af (patch)
tree8b5d0bd7281bce9f308fec636204d20a29b4752a /gnustep-base/libobjc2/files
parent82fd88ea93e273f4b02580552f808b6305d1e840 (diff)
gentoo auto-resync : 27:03:2024 - 01:01:27
Diffstat (limited to 'gnustep-base/libobjc2/files')
-rw-r--r--gnustep-base/libobjc2/files/libobjc2-2.1-eh_trampoline.patch27
-rw-r--r--gnustep-base/libobjc2/files/libobjc2-2.1-pthread_link.patch12
2 files changed, 0 insertions, 39 deletions
diff --git a/gnustep-base/libobjc2/files/libobjc2-2.1-eh_trampoline.patch b/gnustep-base/libobjc2/files/libobjc2-2.1-eh_trampoline.patch
deleted file mode 100644
index c956d15fbd59..000000000000
--- a/gnustep-base/libobjc2/files/libobjc2-2.1-eh_trampoline.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 4e07fb8457266b76311b2bf3dc5dbe8db790c0b5 Mon Sep 17 00:00:00 2001
-From: David Chisnall <github@theravensnest.org>
-Date: Wed, 26 Aug 2020 16:37:06 +0100
-Subject: [PATCH] Don't use CXXFLAGS when compiling eh_trampoline.cc
-
-The way that we were doing this didn't handle multiple flags and we
-actually don't want the user to override these flags because that file
-needs to be compiled in a very specific way.
-
-Fixes #177
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e2746e9..80b7dfe 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -317,7 +317,7 @@ if (ENABLE_OBJCXX)
- endif()
- endif ()
- add_custom_command(OUTPUT eh_trampoline.s
-- COMMAND ${CMAKE_CXX_COMPILER} ${CMAKE_CXX_FLAGS} -fPIC -S "${CMAKE_SOURCE_DIR}/eh_trampoline.cc" -o - -fexceptions -fno-inline | sed "s/__gxx_personality_v0/test_eh_personality/g" > "${CMAKE_BINARY_DIR}/eh_trampoline.s"
-+ COMMAND ${CMAKE_CXX_COMPILER} -fPIC -S "${CMAKE_SOURCE_DIR}/eh_trampoline.cc" -o - -fexceptions -fno-inline | sed "s/__gxx_personality_v0/test_eh_personality/g" > "${CMAKE_BINARY_DIR}/eh_trampoline.s"
- MAIN_DEPENDENCY eh_trampoline.cc)
- list(APPEND libobjc_ASM_SRCS eh_trampoline.s)
- list(APPEND libobjc_CXX_SRCS objcxx_eh.cc)
diff --git a/gnustep-base/libobjc2/files/libobjc2-2.1-pthread_link.patch b/gnustep-base/libobjc2/files/libobjc2-2.1-pthread_link.patch
deleted file mode 100644
index 4d6f1d517db1..000000000000
--- a/gnustep-base/libobjc2/files/libobjc2-2.1-pthread_link.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur libobjc2-2.1.orig/CMakeLists.txt libobjc2-2.1/CMakeLists.txt
---- libobjc2-2.1.orig/CMakeLists.txt 2020-08-23 17:10:20.000000000 +0200
-+++ libobjc2-2.1/CMakeLists.txt 2020-09-03 10:51:38.716078009 +0200
-@@ -344,7 +344,7 @@
- # threading implementation (we do for everything except thread-local storage)
- set(CMAKE_THREAD_PREFER_PTHREAD)
- include(FindThreads)
--set(objc_LINK_FLAGS "${objc_LINK_FLAGS} ${CMAKE_THREAD_LIBS_INIT}")
-+target_link_libraries(objc Threads::Threads)
-
-
-