summaryrefslogtreecommitdiff
path: root/gnome-extra/libgsf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-extra/libgsf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-extra/libgsf')
-rw-r--r--gnome-extra/libgsf/Manifest5
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild39
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.43.ebuild39
-rw-r--r--gnome-extra/libgsf/metadata.xml11
4 files changed, 94 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
new file mode 100644
index 000000000000..8e868b0c59a0
--- /dev/null
+++ b/gnome-extra/libgsf/Manifest
@@ -0,0 +1,5 @@
+DIST libgsf-1.14.41.tar.xz 616944 BLAKE2B 300da197dcbd5568758da21ea25b25636fcd7b16483a5b526e1c9e0242145208580f6edd41ac1028b7b51fe159eab506a32947ef81beb47883cf133bf2ea9cb7 SHA512 e3892500288e5d1d9e46cdd3940d872ae2504fe54babe2dc085218c3e1a5aff5a7220c88bde730239af4a56c340a22f47337280b8892f0ab31e1e751adea9bc3
+DIST libgsf-1.14.43.tar.xz 618272 BLAKE2B a381125ce75d06ae4bf1c9dbe9b2e207534ff7c3310e40984e482bc5120eae45a7e3ed4cfd878890037f31ee540c700dea3120119b9a533fa79cab317a0c83a8 SHA512 bb487de9358c057fc73f3414c9515726315be9b6d78456253daaca1cbd58281de8766e0b72914532d63fab04d3ae2cf90f711f436c7b4f70620d77e8a7802ac9
+EBUILD libgsf-1.14.41-r1.ebuild 1004 BLAKE2B be7fb620de1def1bcb5a3431c5d8d8416db4ee10ab67d033201ab9c83b11340e96c58f640c61877407d22b81f5abf020597f07d07219ba08c618be44e7b70e90 SHA512 852c7872d67ac45243fb75986064db62e2022bacd714cecbb9613d5f7fc0fd961ffef89c13ad4f57de89791d9df12db1f76e030d9536262edaaae2b8fb13db0c
+EBUILD libgsf-1.14.43.ebuild 1005 BLAKE2B 9eaf6b7b19bc908bd901be7cb0c12edfad4b2efad49ae40fb6d9295ab1fd81221df6bc54958044f57311c2c08ed4166f0d6e13929cec7bbe4907f9adf86c1031 SHA512 799f7bcc275d74c5ba739e31b60cca301649b06ba3ffe0a86c0fba5138a2a883db2fea3a3b81122cced6b5c3d862f7bd42da8c7e6bb3ccc0c18e5bdcc6a91486
+MISC metadata.xml 320 BLAKE2B 0724d11438ccaab9b8665d8bc0c9787fce2fc77c1d7b45b8400a66bfcf82c904c73dda016327ab27c81eb2c1574a0f568bcc04ed579c5cc0f8f15dc6d52762a7 SHA512 605b3ee95fa1f26d46a52ad9e9e6f14b4ee193bd2427336afa2a2f6379287bbb121cb98629afbc146bc46fb721871143c73dd9af805b27a1d1ac0d912dd7a4f0
diff --git a/gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild b/gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild
new file mode 100644
index 000000000000..24145aa1ebba
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.41-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}
diff --git a/gnome-extra/libgsf/libgsf-1.14.43.ebuild b/gnome-extra/libgsf/libgsf-1.14.43.ebuild
new file mode 100644
index 000000000000..b0aa05ab0d02
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.43.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}
diff --git a/gnome-extra/libgsf/metadata.xml b/gnome-extra/libgsf/metadata.xml
new file mode 100644
index 000000000000..88797e4b6d00
--- /dev/null
+++ b/gnome-extra/libgsf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="gtk">Enable use of gdk in thumbnailer</flag>
+</use>
+</pkgmetadata>