summaryrefslogtreecommitdiff
path: root/gnome-extra/libgsf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 11:12:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 11:12:20 +0100
commit7aa28e7310855bc5ef0d32b22e8b58eec55c28c9 (patch)
tree9ceae60214a212f74f44e47506754fdeafb6947a /gnome-extra/libgsf/files
parent2099ff9b640e648be67527e29760263a7c6274e5 (diff)
gentoo auto-resync : 28:04:2023 - 11:12:20
Diffstat (limited to 'gnome-extra/libgsf/files')
-rw-r--r--gnome-extra/libgsf/files/1.14.50-configure-clang16.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/files/1.14.50-configure-clang16.patch b/gnome-extra/libgsf/files/1.14.50-configure-clang16.patch
new file mode 100644
index 000000000000..c28811401e82
--- /dev/null
+++ b/gnome-extra/libgsf/files/1.14.50-configure-clang16.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/898818
+https://gitlab.gnome.org/GNOME/libgsf/-/merge_requests/13
+
+From 167d7f96c81683392933ddb8c427e5d7c8ce284d Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 27 Apr 2023 20:34:34 +0200
+Subject: [PATCH] configure.ac: Avoid implicit int in libbz2 probe
+
+Otherwise, this probe will always fail with future compilers,
+which are likely not to support implict ints by default.
+--- a/configure.ac
++++ b/configure.ac
+@@ -427,7 +427,7 @@ if test "x$test_bz2" = xtrue ; then
+ #undef VERSION
+ #undef HAVE_STDLIB_H
+ #include <bzlib.h>
+- main ()
++ int main (void)
+ {
+ return BZ2_bzDecompressInit (NULL, 0, 0);
+ }
+--
+GitLab