summaryrefslogtreecommitdiff
path: root/gnome-extra/gucharmap/gucharmap-9.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnome-extra/gucharmap/gucharmap-9.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'gnome-extra/gucharmap/gucharmap-9.0.2.ebuild')
-rw-r--r--gnome-extra/gucharmap/gucharmap-9.0.2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/gucharmap-9.0.2.ebuild b/gnome-extra/gucharmap/gucharmap-9.0.2.ebuild
new file mode 100644
index 000000000000..edc765ed8bfe
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-9.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala versionator
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+
+LICENSE="GPL-3"
+SLOT="2.90"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+
+IUSE="debug +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+UNICODE_VERSION=$(get_version_component_range 1-2)
+
+COMMON_DEPEND="
+ =app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/pango-1.2.1[introspection?]
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gucharmap-3:0
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.1.2 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # prevent file collisions with slot 0
+ sed -e "s:GETTEXT_PACKAGE=gucharmap$:GETTEXT_PACKAGE=gucharmap-${SLOT}:" \
+ -i configure.ac configure || die "sed configure.ac configure failed"
+
+ # avoid autoreconf
+ sed -e 's/-Wall //g' -i configure || die "sed failed"
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # unihan is not really conditional
+ # https://bugzilla.gnome.org/show_bug.cgi?id=768210#c5
+ gnome2_src_configure \
+ --disable-static \
+ --with-unicode-data=/usr/share/unicode-data \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}