summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-weather-in-the-clock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-04 21:03:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-04 21:03:51 +0000
commitc4d92ab721dfc646b4a58429d965e9446294ce26 (patch)
tree8c0c331362f99c256c191229ac424b1cc8698005 /gnome-extra/gnome-shell-extension-weather-in-the-clock
parent5565fb7867ee9faddf046e42a0a3a1a207803938 (diff)
gentoo auto-resync : 04:12:2022 - 21:03:51
Diffstat (limited to 'gnome-extra/gnome-shell-extension-weather-in-the-clock')
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest4
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024.ebuild49
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml3
3 files changed, 55 insertions, 1 deletions
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest b/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
index 6abcd969b3b6..1bc341f7b0d1 100644
--- a/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
@@ -1,3 +1,5 @@
DIST gnome-shell-extension-weather-in-the-clock-20220504.tar.gz 127002 BLAKE2B 38ad139e29660f8c91629048140c4a2ed7578376ad5e13c8138eda8c487ccfdbdd7fd1a3b1ce7d85407d0a2486c40e776f665cf11c897b218477c8e6d17b187d SHA512 27109e25e0e630233a895576e691c5daa550bb032bd748f6105560553ed05f5a8a47a3eb27ae90eee24dbff2508fed5420d1f81ceb4879f11ef0a98c63616923
+DIST gnome-shell-extension-weather-in-the-clock-20221024.tar.gz 127100 BLAKE2B daf0feb6730351c35bc0c66e54a39df78095eb284774c1689ffe7918afee329e1ab32a54657635ba6758f25fdee0de6d1ec39e007653925da87b3f967a1c4934 SHA512 7ebc1c7368b6e07e9186a3b2a19ee4aaedb0f897b31ad37d33153d58e961dfb9b6249bac287aa51fb110ad28c4858739b7ebc7a82a1301971f3c95891591a417
EBUILD gnome-shell-extension-weather-in-the-clock-20220504.ebuild 1082 BLAKE2B 11638e96c13e231bf39977561aff843abd83cec3fd5beb2a8b862086809c5d2489ee42d473caea53c07fcc5826912ecd1c1d8f3d4e0d8d2b4840b0f21d12ce93 SHA512 6df67d5e70a34f1ffab2ac728a227e6789b5eefd7120b43a8f5b3842130c729bceff3bb949b8513f7d65aecf9265f435fbf02a6e9988d1719555507517dc54e8
-MISC metadata.xml 241 BLAKE2B cb0374238d11e2a3f28f23b7049da09babd4310a99862738acfb7ba554f7758ac68cd09d1eb7a29068195c27010a846a540ed2c09b88fd043b37fb4f0762150f SHA512 b2c1d3e2cb6760ed4682da82af5370adcacd48afd558efa1abf84d955067b2ad32eda034af8cef95c71409622f97fa0113f2e07bee328f2d03512908ae931050
+EBUILD gnome-shell-extension-weather-in-the-clock-20221024.ebuild 1084 BLAKE2B f1b52e9198beae0df1fea805f8c734799e75a1ffaa360c54bd0dc0ea756ea61ad21e94fda989ab44d0b190fe9f1acc7a116efcaaf146b739ea8f18b11214396f SHA512 7e70681f1ce62bc25439d701502155deeb5a02d6c8137a6f8dc4ffea95ffae9dad04eab269f50eebe119a06c50e92f0baebee2f26779e821f3794cdca3eed0e2
+MISC metadata.xml 317 BLAKE2B ed39479ce5dd8dacc6091575826c37509f00e28cd3a59ea7147e09e142d263ce5e3b27e7e74995ba0fd4a7559f9e47b96ab64a39114c079d87e80b9d0fd3d7cf SHA512 a04383c0ba503df6fd72aac11a833baea2a175d449b9f5b64a2b6a709fe52ef46210e37870b77cb36efb4e30506ddb9ebe5d831bd5f209f241bbff59ba3e4fa3
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024.ebuild b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024.ebuild
new file mode 100644
index 000000000000..dde0961d76b0
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Display the current weather in the clock"
+HOMEPAGE="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock"
+COMMIT="38ba36090961a37260215ae04f4a7e0a1377da95"
+SRC_URI="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+ gnome-extra/gnome-weather
+"
+DEPEND=""
+BDEPEND=""
+
+extension_uuid="weatherintheclock@JasonLG1979.github.io"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/gnome-shell/extensions/
+ doins -r "${extension_uuid}"
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml b/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml
index 3947e1bf6d57..372c407cc856 100644
--- a/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml
@@ -5,4 +5,7 @@
<email>pacho@gentoo.org</email>
</maintainer>
<stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">wez/wezterm</remote-id>
+ </upstream>
</pkgmetadata>