summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-42.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-42.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-42.ebuild')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-42.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-42.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-42.ebuild
new file mode 100644
index 000000000000..5261f65d1d5b
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-42.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson
+
+DESCRIPTION="Support Ubuntu AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ dev-libs/libappindicator:3
+ >=gnome-base/gnome-shell-3.34
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}