summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-characters/gnome-characters-45.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 18:03:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 18:03:40 +0100
commit418459f7de9eb29d6db8b61681f39c467d9600e1 (patch)
tree87b23e3d06e1b08b13c64e16503aa7ea88b38a8a /gnome-extra/gnome-characters/gnome-characters-45.0-r1.ebuild
parent522fa4e6f267ba688a264ceec8d6c79663b61219 (diff)
gentoo auto-resync : 08:10:2023 - 18:03:40
Diffstat (limited to 'gnome-extra/gnome-characters/gnome-characters-45.0-r1.ebuild')
-rw-r--r--gnome-extra/gnome-characters/gnome-characters-45.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/gnome-characters/gnome-characters-45.0-r1.ebuild b/gnome-extra/gnome-characters/gnome-characters-45.0-r1.ebuild
new file mode 100644
index 000000000000..42583820622e
--- /dev/null
+++ b/gnome-extra/gnome-characters/gnome-characters-45.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/gjs-1.50
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=gui-libs/gtk-4.6:4[introspection]
+ >=gui-libs/libadwaita-1.2:1=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.36[introspection]
+ gnome-base/gnome-desktop:4
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/glib
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( x11-misc/xvfb-run )
+"
+
+src_test() {
+ meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}