summaryrefslogtreecommitdiff
path: root/gnome-extra/cjs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /gnome-extra/cjs
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'gnome-extra/cjs')
-rw-r--r--gnome-extra/cjs/Manifest4
-rw-r--r--gnome-extra/cjs/cjs-5.2.0.ebuild2
-rw-r--r--gnome-extra/cjs/cjs-5.4.1.ebuild88
3 files changed, 92 insertions, 2 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index 583e6a48602d..2613768ad9fd 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1,3 +1,5 @@
DIST cjs-5.2.0.tar.gz 601982 BLAKE2B 99fe183add425e5178863aa6b0af6aa0579de0dabee72ad9bcc86e2edf0ad13093ce659ac60ed365edb33ff1eb54d54766a7e0df1a65aa64b7da34e5559297c7 SHA512 0ce5cc07be036fa9af93c7d98a179881789f883578a2034c3c28255ef9da96d32b4203fc39311eaea0bdbe5148f13920d72dd24acb717c4e60302b390097a825
-EBUILD cjs-5.2.0.ebuild 1496 BLAKE2B c73308067e90622a3f554737a205c44719ea368f7515715d1742c3365694b5a62555362d1cde894f6daf60a645bcc2f413b380d693d3ff5fa1c61e64fe4ca43b SHA512 f0785ecb4b441aebfd4ba67dec08ee10ab8809eaafc510018873bbaf6fc4b6c2624e3060ae052f3969553dadefb6b6442f07f323888d153c44ffd1c6a9ace580
+DIST cjs-5.4.1.tar.gz 794618 BLAKE2B 6da2cbb5c000d5ef649f64136fd8e886b3b75df6433d62859b2e82080fd52247bd148d4092a92c4b3448718d66254dc0ab6affdf45e13a8eec07d40eef1933a5 SHA512 8fae67c90cfba012420a17d28b94694e86f962c03b69e90e4192d699ce38ca01c9a7be2febf95c16c27a556f101a581006206a9549259486be614cfbd400ef6b
+EBUILD cjs-5.2.0.ebuild 1518 BLAKE2B 017898780e6c372669637e0f147b1dff46c22acc4e02cbc55b1222d55018b84c2edda0f9fefbc822284476ee772ffea53181749eaf1b91bff6a1934599ccbb60 SHA512 8c3f7474d5aa1779a82ba8424741a88ead3e3d0737a873497f4de5c512dc60d554c47fcd71033d80af7fab788901d425d7fbd22c195892a7a3d672327ca74d86
+EBUILD cjs-5.4.1.ebuild 2283 BLAKE2B 30cad64bd266052e4c946ead095baded9c8c493edc7daf573f8c49356dcafb073ef0c9a457a5318639e558b48229268d3f08124bb845334db80db755929abe50 SHA512 3fd8a901dea4714c8066f24bb534bcc7ea326b55d933c9e02852a729f44ba76860925d0d4a057a92c21b445c2a06943f9e0ae4db8b416638137cfc220e8f3c2b
MISC metadata.xml 608 BLAKE2B 7cc55145357fc7b4b46e1a77f19570b60f5dc6207c81efc3b92adf7d5fdb025296d4e6b8b927f193ed7bd0a929274e61c9bdddad2371ca78a497b94fdbe87737 SHA512 672923005e936fd3d08367a8db65318f63217841e6f841623d469c21ce354724f6c2cea853ecca928280b21011d6aa0e133a7830841c9fa44dd8c36402b28066
diff --git a/gnome-extra/cjs/cjs-5.2.0.ebuild b/gnome-extra/cjs/cjs-5.2.0.ebuild
index 63325e9d3c4b..048dbbbf8c0d 100644
--- a/gnome-extra/cjs/cjs-5.2.0.ebuild
+++ b/gnome-extra/cjs/cjs-5.2.0.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
SLOT="0"
IUSE="+cairo examples readline sysprof test"
KEYWORDS="amd64 ~arm64 ~riscv x86"
diff --git a/gnome-extra/cjs/cjs-5.4.1.ebuild b/gnome-extra/cjs/cjs-5.4.1.ebuild
new file mode 100644
index 000000000000..e86d16da7abd
--- /dev/null
+++ b/gnome-extra/cjs/cjs-5.4.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit flag-o-matic meson pax-utils python-any-r1 virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-lang/spidermonkey-78.2.0:78
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gobject-introspection-1.66.1:=
+ >=dev-libs/libffi-3.3:0=
+
+ cairo? ( x11-libs/cairo[glib,svg(+),X] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection]
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ python_fix_shebang build
+}
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}