summaryrefslogtreecommitdiff
path: root/gnome-base/libbonoboui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-base/libbonoboui
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-base/libbonoboui')
-rw-r--r--gnome-base/libbonoboui/Manifest3
-rw-r--r--gnome-base/libbonoboui/libbonoboui-2.24.5-r1.ebuild60
-rw-r--r--gnome-base/libbonoboui/metadata.xml16
3 files changed, 79 insertions, 0 deletions
diff --git a/gnome-base/libbonoboui/Manifest b/gnome-base/libbonoboui/Manifest
new file mode 100644
index 000000000000..f683f4d929a3
--- /dev/null
+++ b/gnome-base/libbonoboui/Manifest
@@ -0,0 +1,3 @@
+DIST libbonoboui-2.24.5.tar.bz2 976250 BLAKE2B b8847b23479ba1c13ee41ebc67031c94572f9f9e5ae88b067da78bac2c78d6c52c6a5bd408246328fb71fa2d1722ce69acaa517c90520cd9fe5e81828988d6ea SHA512 163a8f39d9dad7fc3f1afc55b1a779961d285abe2988ff74bfcad4376e9dbfb91bb3e8212f96f48f91c54a6aff749ba6e00ea2d9add10c76b650f3072b875100
+EBUILD libbonoboui-2.24.5-r1.ebuild 1353 BLAKE2B 9732816f947d6a5ac012df5c32c11d15867a63b0066eb07e64c20c9efba820fd6b820540af2611ba43efdc08e517f586a962bb01d9f42c94624a0c5938dc4137 SHA512 28e09e22b6161b90d4a4be92b8d25fb3c66cc36a1f94f45e288256b5c62a55f65fe9a6065e1320463e3c6e2c4a7ad79c7da0ccde8a7681a93f31e829e6457294
+MISC metadata.xml 744 BLAKE2B 9b0f0bd7470f3486c1e2dc90ef701db7a4d55afd42092904326842651f6b29b02e35a136c69b7e252d6bd458f5f2b4eea384a27bcc69067ef6b9deeeb3e6dd2e SHA512 0f23ea97d68a4c46220dd395343aa63ed8351222f0c8aeeeefe9d9410a397522d7866f4600023653ac683513754480d92c7fffcd551d5f7987b2100ca2b5c370
diff --git a/gnome-base/libbonoboui/libbonoboui-2.24.5-r1.ebuild b/gnome-base/libbonoboui/libbonoboui-2.24.5-r1.ebuild
new file mode 100644
index 000000000000..56b1c70caca9
--- /dev/null
+++ b/gnome-base/libbonoboui/libbonoboui-2.24.5-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="User Interface part of libbonobo"
+HOMEPAGE="https://developer.gnome.org/libbonoboui/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="examples test"
+
+# GTK+ dep due to bug #126565
+RDEPEND="
+ >=gnome-base/libgnomecanvas-1.116
+ >=gnome-base/libbonobo-2.22
+ >=gnome-base/libgnome-2.13.7
+ >=dev-libs/libxml2-2.4.20:2
+ >=gnome-base/gconf-2:2
+ >=x11-libs/gtk+-2.8.12:2
+ >=dev-libs/glib-2.6.0:2
+ >=gnome-base/libglade-1.99.11:2.0
+ >=dev-libs/popt-1.5
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ x11-apps/xrdb
+ sys-devel/gettext
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+"
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/tests//' -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ sed 's/samples//' -i Makefile.am Makefile.in || die "sed 2 failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ addpredict "/root/.gnome2_private"
+ gnome2_src_configure --disable-static
+}
+
+src_test() {
+ addpredict "/root/.gnome2_private"
+ Xemake check
+}
diff --git a/gnome-base/libbonoboui/metadata.xml b/gnome-base/libbonoboui/metadata.xml
new file mode 100644
index 000000000000..561f51608528
--- /dev/null
+++ b/gnome-base/libbonoboui/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<longdescription>
+ computer. It will however make a snappier openoffice than the binary version.
+ The Bonobo UI library provides a number of user interface controls using the
+ Bonobo component framework. This module is heading towards planned deprecation.
+ It will continue to be supported and API/ABI stable throughout the GNOME 2.x
+ series, but we do not recommend using it in new applications unless you require
+ functionality that has not already been moved elsewhere.
+</longdescription>
+</pkgmetadata>