summaryrefslogtreecommitdiff
path: root/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-45_alpha.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-06 16:14:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-06 16:14:21 +0100
commit5c92379e3a6732ff2855a56c60576983ae42e288 (patch)
treecfc3b84baaef518de09d10b5305a3f4abbc16dd7 /gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-45_alpha.ebuild
parent8e3281f71945b4cccca5a44f2f467f3bff4ac45c (diff)
gentoo auto-resync : 06:07:2023 - 16:14:21
Diffstat (limited to 'gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-45_alpha.ebuild')
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-45_alpha.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-45_alpha.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-45_alpha.ebuild
new file mode 100644
index 000000000000..6bf0d1f374e1
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-45_alpha.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Revert change to 'Source Code Pro 10' and 'Cantarell 11' fonts back to generic sans and monospace aliases
+ "${FILESDIR}"/3.32.0-default-fonts.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}