summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-settings-daemon/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /gnome-base/gnome-settings-daemon/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'gnome-base/gnome-settings-daemon/files')
-rw-r--r--gnome-base/gnome-settings-daemon/files/3.32.1-fix-wacom-no-wayland.patch25
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-Allow-udev-optional-on-Linux.patch134
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch24
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch76
4 files changed, 234 insertions, 25 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/3.32.1-fix-wacom-no-wayland.patch b/gnome-base/gnome-settings-daemon/files/3.32.1-fix-wacom-no-wayland.patch
deleted file mode 100644
index ea343c44b6f7..000000000000
--- a/gnome-base/gnome-settings-daemon/files/3.32.1-fix-wacom-no-wayland.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From ec6982cc8b3fccc35dbd5df3c4e22ab94709c66d Mon Sep 17 00:00:00 2001
-From: Vlad Banea <vlb@xiphos.ca>
-Date: Tue, 31 Dec 2019 15:35:41 -0500
-Subject: [PATCH] plugins/wacom: Fix build without WAYLAND
-
----
- plugins/wacom/gsd-wacom-manager.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/plugins/wacom/gsd-wacom-manager.c b/plugins/wacom/gsd-wacom-manager.c
-index e1c8eaa7..92fd96c3 100644
---- a/plugins/wacom/gsd-wacom-manager.c
-+++ b/plugins/wacom/gsd-wacom-manager.c
-@@ -190,7 +190,7 @@ gsd_wacom_manager_class_init (GsdWacomManagerClass *klass)
- static gchar *
- get_device_path (GdkDevice *device)
- {
--#ifdef HAVE_WAYLAND
-+#if HAVE_WAYLAND
- if (gnome_settings_is_wayland ())
- return g_strdup (gdk_wayland_device_get_node_path (device));
- else
---
-2.20.1
-
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-Allow-udev-optional-on-Linux.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-Allow-udev-optional-on-Linux.patch
new file mode 100644
index 000000000000..658f4a3f48ee
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-Allow-udev-optional-on-Linux.patch
@@ -0,0 +1,134 @@
+From 6a44d3a6741da48d769353023c8801d41c969663 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 12 Jul 2020 16:30:59 +0300
+Subject: [PATCH 3/3] Allow udev optional on Linux
+
+---
+ meson.build | 4 ----
+ plugins/power/gsd-backlight.c | 14 +++++++-------
+ plugins/power/meson.build | 6 +++---
+ 3 files changed, 10 insertions(+), 14 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 21d9341d..0a527513 100644
+--- a/meson.build
++++ b/meson.build
+@@ -138,9 +138,6 @@ if enable_gudev
+ gudev_dep = dependency('gudev-1.0')
+ endif
+ config_h.set10('HAVE_GUDEV', enable_gudev)
+-if host_is_linux
+- assert(enable_gudev, 'GUdev is not optional on Linux platforms')
+-endif
+
+ # Check for colord
+ enable_colord = get_option('colord')
+@@ -203,7 +200,6 @@ endif
+
+ # Rfkill
+ enable_rfkill = get_option('rfkill')
+-assert(enable_rfkill or not host_is_linux, 'rfkill is not optional on Linux platforms')
+ if enable_rfkill
+ assert(cc.has_header('linux/rfkill.h'), 'rfkill support requested but RFKill headers not found')
+ assert(enable_gudev, 'GUdev is required for rfkill support')
+diff --git a/plugins/power/gsd-backlight.c b/plugins/power/gsd-backlight.c
+index ca5f2723..f58f5343 100644
+--- a/plugins/power/gsd-backlight.c
++++ b/plugins/power/gsd-backlight.c
+@@ -25,7 +25,7 @@
+ #include "gsd-power-constants.h"
+ #include "gsd-power-manager.h"
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ #include <gudev/gudev.h>
+ #endif /* __linux__ */
+
+@@ -39,7 +39,7 @@ struct _GsdBacklight
+ gint brightness_target;
+ gint brightness_step;
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ GDBusProxy *logind_proxy;
+
+ GUdevClient *udev;
+@@ -77,7 +77,7 @@ G_DEFINE_TYPE_EXTENDED (GsdBacklight, gsd_backlight, G_TYPE_OBJECT, 0,
+ G_IMPLEMENT_INTERFACE (G_TYPE_INITABLE,
+ gsd_backlight_initable_iface_init);)
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ static GUdevDevice*
+ gsd_backlight_udev_get_type (GList *devices, const gchar *type)
+ {
+@@ -478,7 +478,7 @@ gsd_backlight_set_brightness_val_async (GsdBacklight *backlight,
+
+ task = g_task_new (backlight, cancellable, callback, user_data);
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ if (backlight->udev_device != NULL) {
+ BacklightHelperData *task_data;
+
+@@ -831,7 +831,7 @@ gsd_backlight_initable_init (GInitable *initable,
+ return FALSE;
+ }
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ backlight->logind_proxy =
+ g_dbus_proxy_new_for_bus_sync (G_BUS_TYPE_SYSTEM,
+ 0,
+@@ -908,7 +908,7 @@ gsd_backlight_finalize (GObject *object)
+ {
+ GsdBacklight *backlight = GSD_BACKLIGHT (object);
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ g_assert (backlight->active_task == NULL);
+ g_assert (g_queue_is_empty (&backlight->tasks));
+ g_clear_object (&backlight->logind_proxy);
+@@ -961,7 +961,7 @@ gsd_backlight_init (GsdBacklight *backlight)
+ backlight->brightness_val = -1;
+ backlight->brightness_step = 1;
+
+-#ifdef __linux__
++#if defined(__linux__) && defined(HAVE_GUDEV)
+ backlight->active_task = NULL;
+ g_queue_init (&backlight->tasks);
+ #endif /* __linux__ */
+diff --git a/plugins/power/meson.build b/plugins/power/meson.build
+index 69e619f2..6c6ea939 100644
+--- a/plugins/power/meson.build
++++ b/plugins/power/meson.build
+@@ -24,7 +24,7 @@ native_deps = [
+ dependency('gio-2.0', native:true)
+ ]
+
+-if host_is_linux
++if host_is_linux and enable_gudev
+ deps += gudev_dep
+ endif
+
+@@ -66,7 +66,7 @@ gsd_power_enums_update = executable(
+ native: true
+ )
+
+-if host_is_linux
++if host_is_linux and enable_gudev
+ policy = 'org.gnome.settings-daemon.plugins.power.policy'
+
+ policy_in = configure_file(
+@@ -130,7 +130,7 @@ envs.set('BUILDDIR', meson.current_build_dir())
+ envs.set('TOP_BUILDDIR', meson.build_root())
+ envs.set('LD_PRELOAD', 'libumockdev-preload.so.0')
+ envs.set('NO_AT_BRIDGE', '1')
+-envs.set('HAVE_SYSFS_BACKLIGHT', host_is_linux ? '1' : '0')
++envs.set('HAVE_SYSFS_BACKLIGHT', (host_is_linux and enable_gudev) ? '1' : '0')
+
+ if get_option('b_sanitize').split(',').contains('address')
+ # libasan needs to be loaded first; so we need to explicitly preload it
+--
+2.26.2
+
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch
new file mode 100644
index 000000000000..e6b22b301a0d
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Allow-NM-optional-on-Linux.patch
@@ -0,0 +1,24 @@
+From b5b933cf83fc79cc9dd382ddb0ec2567330e24e8 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 8 Sep 2019 18:07:12 +0300
+Subject: [PATCH 2/3] build: Allow NM optional on Linux
+
+---
+ meson.build | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index dce9bfa1..21d9341d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -223,7 +223,6 @@ endif
+
+ # Sharing plugin
+ enable_network_manager = get_option('network_manager')
+-assert(enable_network_manager or not host_is_linux, 'NetworkManager support is not optional on Linux platforms')
+ if enable_network_manager
+ # network manager
+ libnm_dep = dependency('libnm', version: '>= 1.0')
+--
+2.26.2
+
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch
new file mode 100644
index 000000000000..b48007d29848
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch
@@ -0,0 +1,76 @@
+From 0cc1c2f5f5d12169acbb965a21b5d9f6fb4a0767 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Thu, 14 Mar 2019 09:43:00 +0200
+Subject: [PATCH 1/3] build: Make colord and wacom optional and controllable
+ via meson_options
+
+---
+ meson.build | 10 ++++++++--
+ meson_options.txt | 2 ++
+ plugins/meson.build | 4 ++++
+ 3 files changed, 14 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 7dbee64b..dce9bfa1 100644
+--- a/meson.build
++++ b/meson.build
+@@ -142,6 +142,12 @@ if host_is_linux
+ assert(enable_gudev, 'GUdev is not optional on Linux platforms')
+ endif
+
++# Check for colord
++enable_colord = get_option('colord')
++if enable_colord
++ colord_dep = dependency('colord', version: '>= 1.3.5')
++endif
++
+ has_timerfd_create = cc.has_function('timerfd_create')
+ config_h.set10('HAVE_TIMERFD', has_timerfd_create)
+
+@@ -154,8 +160,8 @@ if enable_wayland
+ endif
+ config_h.set10('HAVE_WAYLAND', enable_wayland)
+
+-# wacom (disabled for s390/s390x and non Linux platforms)
+-enable_wacom = host_is_linux_not_s390
++# wacom
++enable_wacom = get_option('wacom')
+ if enable_wacom
+ assert(enable_gudev, 'GUDev support is required for wacom support.')
+ libwacom_dep = dependency('libwacom', version: '>= 0.7')
+diff --git a/meson_options.txt b/meson_options.txt
+index 3e04cf64..6f6eb2fc 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -4,11 +4,13 @@ option('systemd', type: 'boolean', value: true, description: 'Enable systemd int
+
+ option('alsa', type: 'boolean', value: true, description: 'build with ALSA support (not optional on Linux platforms)')
+ option('gudev', type: 'boolean', value: true, description: 'build with gudev device support (not optional on Linux platforms)')
++option('colord', type: 'boolean', value: true, description: 'build with colord support')
+ option('cups', type: 'boolean', value: true, description: 'build with CUPS support')
+ option('network_manager', type: 'boolean', value: true, description: 'build with NetworkManager support (not optional on Linux platforms)')
+ option('rfkill', type: 'boolean', value: true, description: 'build with rfkill support (not optional on Linux platforms)')
+ option('smartcard', type: 'boolean', value: true, description: 'build with smartcard support')
+ option('usb-protection', type: 'boolean', value: true, description: 'build with usb-protection support')
++option('wacom', type: 'boolean', value: true, description: 'build with Wacom devices support')
+ option('wayland', type: 'boolean', value: true, description: 'build with Wayland support')
+ option('wwan', type: 'boolean', value: true, description: 'build with WWAN support')
+ option('colord', type: 'boolean', value: true, description: 'build with colord support')
+diff --git a/plugins/meson.build b/plugins/meson.build
+index 83e01885..20ccb26d 100644
+--- a/plugins/meson.build
++++ b/plugins/meson.build
+@@ -20,6 +20,10 @@ all_plugins = [
+
+ disabled_plugins = []
+
++if not enable_colord
++ disabled_plugins += ['color']
++endif
++
+ if not enable_smartcard
+ disabled_plugins += ['smartcard']
+ endif
+--
+2.26.2
+