summaryrefslogtreecommitdiff
path: root/gnome-base/gdm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnome-base/gdm/files
reinit the tree, so we can have metadata
Diffstat (limited to 'gnome-base/gdm/files')
-rw-r--r--gnome-base/gdm/files/49-keychain-r19
-rw-r--r--gnome-base/gdm/files/50-ssh-agent-r110
-rw-r--r--gnome-base/gdm/files/gdm-2.32.0-xinitrc-ssh-agent.patch32
-rw-r--r--gnome-base/gdm/files/gdm-3.22.1-pam-module-dir.patch52
-rw-r--r--gnome-base/gdm/files/gdm-3.8.4-fingerprint-auth.patch29
-rw-r--r--gnome-base/gdm/files/gdm-3.8.4-logo.patch25
6 files changed, 157 insertions, 0 deletions
diff --git a/gnome-base/gdm/files/49-keychain-r1 b/gnome-base/gdm/files/49-keychain-r1
new file mode 100644
index 000000000000..51a1ca87905c
--- /dev/null
+++ b/gnome-base/gdm/files/49-keychain-r1
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+# source keychain variables
+
+keychain="`which keychain 2>/dev/null`"
+if [ -n "$keychain" ] && [ -x "$keychain" ] && [ -f "$HOME/.bash_profile" ]
+then
+ . "${HOME}/.bash_profile"
+fi
diff --git a/gnome-base/gdm/files/50-ssh-agent-r1 b/gnome-base/gdm/files/50-ssh-agent-r1
new file mode 100644
index 000000000000..4d94fb04a14a
--- /dev/null
+++ b/gnome-base/gdm/files/50-ssh-agent-r1
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# add ssh-agent if found
+
+sshagent="`which ssh-agent 2>/dev/null`"
+if [ -n "$sshagent" ] && [ -x "$sshagent" ] && [ -z "$SSH_AUTH_SOCK" ]; then
+ command="$sshagent -- $command"
+elif [ -z "$sshagent" ] ; then
+ echo "$0: ssh-agent not found!"
+fi
diff --git a/gnome-base/gdm/files/gdm-2.32.0-xinitrc-ssh-agent.patch b/gnome-base/gdm/files/gdm-2.32.0-xinitrc-ssh-agent.patch
new file mode 100644
index 000000000000..bfd8398af2b3
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-2.32.0-xinitrc-ssh-agent.patch
@@ -0,0 +1,32 @@
+From c0581264d5e2b412aa27dc30623512b461024e4f Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 2 Nov 2010 23:19:31 +0100
+Subject: [PATCH 2/4] ssh-agent handling must be done at xinitrc.d
+
+Gentoo bug: #220603
+---
+ data/Xsession.in | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/data/Xsession.in b/data/Xsession.in
+index 201be92..88f1fd9 100755
+--- a/data/Xsession.in
++++ b/data/Xsession.in
+@@ -191,14 +191,6 @@ if [ -d /etc/X11/xinit/xinitrc.d ]; then
+ done
+ fi
+
+-# add ssh-agent if found
+-sshagent="`gdmwhich ssh-agent`"
+-if [ -n "$sshagent" ] && [ -x "$sshagent" ] && [ -z "$SSH_AUTH_SOCK" ]; then
+- command="$sshagent -- $command"
+-elif [ -z "$sshagent" ] ; then
+- echo "$0: ssh-agent not found!"
+-fi
+-
+ echo "$0: Setup done, will execute: $command"
+
+ eval exec $command
+--
+1.8.5.1
+
diff --git a/gnome-base/gdm/files/gdm-3.22.1-pam-module-dir.patch b/gnome-base/gdm/files/gdm-3.22.1-pam-module-dir.patch
new file mode 100644
index 000000000000..7dc4392e41cb
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-3.22.1-pam-module-dir.patch
@@ -0,0 +1,52 @@
+From 4fc9023bb86689f1391651fa744d9e63ee1d7bbc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Mon, 21 Nov 2016 08:18:32 +0100
+Subject: [PATCH] pam_gdm: allow setting pam module dir at configure time
+
+Code taken almost verbatim from gnome-keyring.
+---
+ configure.ac | 10 +++++++++-
+ pam_gdm/Makefile.am | 2 +-
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index dd98992..e0074dd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -476,7 +476,7 @@ dnl ---------------------------------------------------------------------------
+ dnl - Check for PAM stuff
+ dnl ---------------------------------------------------------------------------
+
+-dnl PAM prefix
++dnl PAM prefix (configuration files)
+ withval=""
+ AC_ARG_WITH(pam-prefix,
+ AS_HELP_STRING([--with-pam-prefix=<prefix>],
+@@ -492,6 +492,14 @@ else
+ fi
+ AC_SUBST(PAM_PREFIX)
+
++dnl PAM dir (dynamic modules)
++AC_ARG_WITH([pam-dir],
++ [AC_HELP_STRING([--with-pam-dir=DIR],
++ [directory to install pam modules in])],
++ [], [with_pam_dir='${libdir}/security'])
++PAM_DEST_DIR="$with_pam_dir"
++AC_SUBST(PAM_DEST_DIR)
++
+ have_pam=no
+ AC_CHECK_LIB(pam, pam_start, have_pam=yes)
+
+diff --git a/pam_gdm/Makefile.am b/pam_gdm/Makefile.am
+index 61d672b..980b31c 100644
+--- a/pam_gdm/Makefile.am
++++ b/pam_gdm/Makefile.am
+@@ -36,4 +36,4 @@ pam_gdm_LTLIBRARIES = \
+ pam_gdm.la \
+ $(END_OF_LIST)
+
+-pam_gdmdir = $(libdir)/security
++pam_gdmdir = $(PAM_DEST_DIR)
+--
+2.10.2
+
diff --git a/gnome-base/gdm/files/gdm-3.8.4-fingerprint-auth.patch b/gnome-base/gdm/files/gdm-3.8.4-fingerprint-auth.patch
new file mode 100644
index 000000000000..cd19077a5f1d
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-3.8.4-fingerprint-auth.patch
@@ -0,0 +1,29 @@
+From 75fe02c2b383b27b202940bdedd7d8d2c64169fb Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 30 Jul 2013 22:56:30 -0400
+Subject: [PATCH 3/4] Gentoo does not have a fingerprint-auth pam stack
+
+---
+ data/pam-exherbo/gdm-fingerprint.pam | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/data/pam-exherbo/gdm-fingerprint.pam b/data/pam-exherbo/gdm-fingerprint.pam
+index 41639ec..d9633fb 100644
+--- a/data/pam-exherbo/gdm-fingerprint.pam
++++ b/data/pam-exherbo/gdm-fingerprint.pam
+@@ -1,6 +1,11 @@
+ account include system-login
+
+-auth substack fingerprint-auth
++auth optional pam_env.so
++auth required pam_tally2.so onerr=succeed
++auth required pam_shells.so
++auth required pam_nologin.so
++auth required pam_fprintd.so
++auth required pam_permit.so
+ auth optional pam_gnome_keyring.so
+
+ password required pam_deny.so
+--
+1.8.5.1
+
diff --git a/gnome-base/gdm/files/gdm-3.8.4-logo.patch b/gnome-base/gdm/files/gdm-3.8.4-logo.patch
new file mode 100644
index 000000000000..151d4bc77f42
--- /dev/null
+++ b/gnome-base/gdm/files/gdm-3.8.4-logo.patch
@@ -0,0 +1,25 @@
+From bcc651df77a429a6bf9b13892f71fedb1b87a069 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 11 Dec 2013 22:46:58 +0100
+Subject: [PATCH 4/4] Apply Gentoo branding
+
+---
+ data/org.gnome.login-screen.gschema.xml.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/data/org.gnome.login-screen.gschema.xml.in b/data/org.gnome.login-screen.gschema.xml.in
+index 03da374..5e81bc0 100644
+--- a/data/org.gnome.login-screen.gschema.xml.in
++++ b/data/org.gnome.login-screen.gschema.xml.in
+@@ -31,7 +31,7 @@
+ </_description>
+ </key>
+ <key name="logo" type="s">
+- <default>''</default>
++ <default>'/usr/share/pixmaps/gentoo-gdm.svg'</default>
+ <_summary>
+ Path to small image at top of user list
+ </_summary>
+--
+1.8.5.1
+