summaryrefslogtreecommitdiff
path: root/gnome-base/dconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-base/dconf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-base/dconf')
-rw-r--r--gnome-base/dconf/Manifest3
-rw-r--r--gnome-base/dconf/dconf-0.26.1.ebuild62
-rw-r--r--gnome-base/dconf/metadata.xml8
3 files changed, 73 insertions, 0 deletions
diff --git a/gnome-base/dconf/Manifest b/gnome-base/dconf/Manifest
new file mode 100644
index 000000000000..2c1a7f32d9de
--- /dev/null
+++ b/gnome-base/dconf/Manifest
@@ -0,0 +1,3 @@
+DIST dconf-0.26.1.tar.xz 218516 BLAKE2B ddb23a1f6519b5460903b1a91ba48242f144a768f7ec5b9e82953589474df998061a4fbfb3605027cb51db44f7e49f88c774a735600de2bedaf8889b58e050bc SHA512 4d2b4afce189e448e3bd4e9c2f9d3d5eec6c694748aec87a9a8de047296c858772a5234dbcace8e84d99c5378d2d1ba35cafb5e5ea7efca25c10a53a55b8b6da
+EBUILD dconf-0.26.1.ebuild 1524 BLAKE2B 939422aa7f6d0c02a36dc3cc1384c223f88b87d6a49cf8a05657280acbcf811641cfee0eabba70bba3aa3f00563523711840251a9454de617bbf8d568a76cbc0 SHA512 aea1a40fbe95e4c38687aef9f6e77d04fbc26c95ef9a54f1c59765cd3367ee95c2a43c05e4eb9b9ffc73fe7f44b30e6674ee8af523e6a194af4bc8f2b9ee1543
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-base/dconf/dconf-0.26.1.ebuild b/gnome-base/dconf/dconf-0.26.1.ebuild
new file mode 100644
index 000000000000..dba082d37e7e
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.26.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/action/show/Projects/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ sys-apps/dbus
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ VALAC=$(type -P true)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}
diff --git a/gnome-base/dconf/metadata.xml b/gnome-base/dconf/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/gnome-base/dconf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>