summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /games-util
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7214 -> 7388 bytes
-rw-r--r--games-util/gamemode/Manifest4
-rw-r--r--games-util/gamemode/gamemode-1.2.ebuild102
-rw-r--r--games-util/gamemode/gamemode-9999.ebuild102
-rw-r--r--games-util/gamemode/metadata.xml16
-rw-r--r--games-util/lgogdownloader/Manifest4
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.4.ebuild (renamed from games-util/lgogdownloader/lgogdownloader-3.3.ebuild)2
7 files changed, 227 insertions, 3 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index c86f11d2caad..50c9877f3ed5 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/gamemode/Manifest b/games-util/gamemode/Manifest
new file mode 100644
index 000000000000..3634b04b348f
--- /dev/null
+++ b/games-util/gamemode/Manifest
@@ -0,0 +1,4 @@
+DIST gamemode-1.2.tar.xz 38536 BLAKE2B af39b8c0585c522afa72238b8332a6a5301d36b3c53e50652a78c41788eae9f5cb319cad06eaf6f345c50f934e188df4c78d70efbad919dd6897d3350d14e568 SHA512 233602e5e93b6cfcc742510dafb00dc826000d0c8618a693e9a579dc3b31c546d22c0545084cfb78c6085226e6b0e26c066078bc1871d36d5fb90828cf63cea9
+EBUILD gamemode-1.2.ebuild 3239 BLAKE2B 43f63f18aa08f8206ccf914fabdf19f5e060d7c6da5670cb766b25f8f3338dcd9bbf945105da7e9671e36bbba4094bb71b5f249f1f218e4621680f8dd6d7c375 SHA512 9b0ff9ae1e19779748d88bf1c87431a1484b022d4aab24a5a339ccf848e424aef1cf4fd206616b63f132e4abfe8055c9a51d05a29b3953a5af5b5ae3a08d7aca
+EBUILD gamemode-9999.ebuild 3239 BLAKE2B 43f63f18aa08f8206ccf914fabdf19f5e060d7c6da5670cb766b25f8f3338dcd9bbf945105da7e9671e36bbba4094bb71b5f249f1f218e4621680f8dd6d7c375 SHA512 9b0ff9ae1e19779748d88bf1c87431a1484b022d4aab24a5a339ccf848e424aef1cf4fd206616b63f132e4abfe8055c9a51d05a29b3953a5af5b5ae3a08d7aca
+MISC metadata.xml 530 BLAKE2B 14e10e8800bca7ad7e412916ee250a4c9dbc5ed78feb99fbb9ec1feb6cc60cbf96494676eaf48200781f9e25bd330d97e16e7cbd46120df79a3e7affb8361d7e SHA512 6a080b2ec0af531ef9c5d989927a2bef7dd8870c27a5edccc9e61bc9c35cb8bc11c1b781aa003dbca470a2c8172b10f5317be6cca6c6d3d6bef206e91fe7e75c
diff --git a/games-util/gamemode/gamemode-1.2.ebuild b/games-util/gamemode/gamemode-1.2.ebuild
new file mode 100644
index 000000000000..6ac471006aa0
--- /dev/null
+++ b/games-util/gamemode/gamemode-1.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils user
+
+DESCRIPTION="Optimise Linux system performance on demand"
+HOMEPAGE="https://github.com/FeralInteractive/gamemode"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
+ GAMEMODE_GIT_PTR="master"
+ inherit git-r3
+else
+ GAMEMODE_GIT_PTR="${PV}"
+ SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/systemd-236[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ elog
+ elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"
+ elog "feature. Examples of kernels providing that are sys-kernel/ck-source"
+ elog "and sys-kernel/pf-sources."
+ elog
+ elog "Support for soft realtime is completely optional. It may provide the"
+ elog "following benefits with systems having at least four CPU cores:"
+ elog
+ elog " * more CPU shares allocated exclusively to the game"
+ elog " * reduced input lag and reduced thread latency"
+ elog " * more consistent frame times resulting in less microstutters"
+ elog
+ elog "You probably won't benefit from soft realtime mode and thus don't need"
+ elog "SCHED_ISO if:"
+ elog
+ elog " * Your CPU has less than four cores because the game may experience"
+ elog " priority inversion with the graphics driver (thus heuristics"
+ elog " automatically disable SCHED_ISO usage then)"
+ elog " * Your game uses busy-loops to interface with the graphics driver"
+ elog " but you may still force SCHED_ISO per configuation file, YMMV,"
+ elog " it depends on the graphics driver implementation, i.e. usage of"
+ elog " __GL_THREADED_OPTIMIZATIONS or similar."
+ elog " * If your game causes more than 70% CPU usage across all cores,"
+ elog " SCHED_ISO automatically turns off and on depending on usage and"
+ elog " is processed with higher-than-normal priority then (renice)."
+ elog " This auto-switching may result in a lesser game experience."
+ elog
+ elog "For more info look at:"
+ elog "https://github.com/FeralInteractive/gamemode/blob/${GAMEMODE_GIT_PTR}/README.md"
+ elog
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ -Dwith-examples=false
+ -Dwith-daemon=false
+ )
+ fi
+ meson_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+ insinto /etc/security/limits.d
+ newins - 45-gamemode.conf <<-EOF
+ @gamemode - nice -10
+ EOF
+}
+
+pkg_postinst() {
+ enewgroup gamemode
+
+ elog
+ elog "GameMode can renice your games. You need to be in the gamemode group for this to work."
+ elog "Run the following command as root to add your user:"
+ elog "# gpasswd -a USER gamemode # with USER = your user name"
+ elog
+
+ elog "Enable and start the daemon in your systemd user instance, then add"
+ elog "LD_PRELOAD=\$LD_PRELOAD:/usr/\$LIB/libgamemodeauto.so %command%"
+ elog "to the start options of any steam game to enable the performance"
+ elog "governor as you start the game."
+ elog
+}
diff --git a/games-util/gamemode/gamemode-9999.ebuild b/games-util/gamemode/gamemode-9999.ebuild
new file mode 100644
index 000000000000..6ac471006aa0
--- /dev/null
+++ b/games-util/gamemode/gamemode-9999.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils user
+
+DESCRIPTION="Optimise Linux system performance on demand"
+HOMEPAGE="https://github.com/FeralInteractive/gamemode"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
+ GAMEMODE_GIT_PTR="master"
+ inherit git-r3
+else
+ GAMEMODE_GIT_PTR="${PV}"
+ SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/systemd-236[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ elog
+ elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"
+ elog "feature. Examples of kernels providing that are sys-kernel/ck-source"
+ elog "and sys-kernel/pf-sources."
+ elog
+ elog "Support for soft realtime is completely optional. It may provide the"
+ elog "following benefits with systems having at least four CPU cores:"
+ elog
+ elog " * more CPU shares allocated exclusively to the game"
+ elog " * reduced input lag and reduced thread latency"
+ elog " * more consistent frame times resulting in less microstutters"
+ elog
+ elog "You probably won't benefit from soft realtime mode and thus don't need"
+ elog "SCHED_ISO if:"
+ elog
+ elog " * Your CPU has less than four cores because the game may experience"
+ elog " priority inversion with the graphics driver (thus heuristics"
+ elog " automatically disable SCHED_ISO usage then)"
+ elog " * Your game uses busy-loops to interface with the graphics driver"
+ elog " but you may still force SCHED_ISO per configuation file, YMMV,"
+ elog " it depends on the graphics driver implementation, i.e. usage of"
+ elog " __GL_THREADED_OPTIMIZATIONS or similar."
+ elog " * If your game causes more than 70% CPU usage across all cores,"
+ elog " SCHED_ISO automatically turns off and on depending on usage and"
+ elog " is processed with higher-than-normal priority then (renice)."
+ elog " This auto-switching may result in a lesser game experience."
+ elog
+ elog "For more info look at:"
+ elog "https://github.com/FeralInteractive/gamemode/blob/${GAMEMODE_GIT_PTR}/README.md"
+ elog
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ -Dwith-examples=false
+ -Dwith-daemon=false
+ )
+ fi
+ meson_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+ insinto /etc/security/limits.d
+ newins - 45-gamemode.conf <<-EOF
+ @gamemode - nice -10
+ EOF
+}
+
+pkg_postinst() {
+ enewgroup gamemode
+
+ elog
+ elog "GameMode can renice your games. You need to be in the gamemode group for this to work."
+ elog "Run the following command as root to add your user:"
+ elog "# gpasswd -a USER gamemode # with USER = your user name"
+ elog
+
+ elog "Enable and start the daemon in your systemd user instance, then add"
+ elog "LD_PRELOAD=\$LD_PRELOAD:/usr/\$LIB/libgamemodeauto.so %command%"
+ elog "to the start options of any steam game to enable the performance"
+ elog "governor as you start the game."
+ elog
+}
diff --git a/games-util/gamemode/metadata.xml b/games-util/gamemode/metadata.xml
new file mode 100644
index 000000000000..05078a2e7821
--- /dev/null
+++ b/games-util/gamemode/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hurikhan77+bgo@gmail.com</email>
+ <name>Kai Krakow</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/FeralInteractive/gamemode/issues</bugs-to>
+ <remote-id type="github">FeralInteractive/gamemode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
index 0e172b46e3b5..b0a9a90c51cc 100644
--- a/games-util/lgogdownloader/Manifest
+++ b/games-util/lgogdownloader/Manifest
@@ -1,4 +1,4 @@
-DIST lgogdownloader-3.3.tar.gz 73873 BLAKE2B c2c4c56d6afcc4c103cc32a308be25252888f7668d7488d3aa2eec860f8e2694c62fe25a27e1f24132895d0a8683a226ca95667dac4e7837886b07cfd0821855 SHA512 7af67c440e88bcfbbd6f59b44b8cfd81fe9cee041715d4da968be3aedfe4301a5377ce61354a5cc093588d89300c88c862d9228672a2d79613419dce3619f4c9
-EBUILD lgogdownloader-3.3.ebuild 617 BLAKE2B fcc5b4667ea14cb9ed71edcec85a67778a4f8a26c4c2cbb0bd6db7d4236b1679605286d6cb4de5c7d8f640b98bf4934cefc11b4ef90f331e9c9ec9e8d4643ccc SHA512 1ba1653d7b228c0d30496209bc422d57cc08af72cb978e69f95e5caebf97ec080b8d2cecc99f491040d54c40c8b0cf507d60b3c70c7ef628e40d2ba98f2d0537
+DIST lgogdownloader-3.4.tar.gz 86362 BLAKE2B a6f0f7b69fc3707c5788f8c25b0669887fde2f44c585f069cbada40791283e37f01d6adcc216712bb6f283a4a46dc8ebecb4861000b7db58d45be777f5b55a56 SHA512 852a335e21c199e9fc49a1cf07fd218d487cb70ebf4ed2a2c81e46477df7629999bc5c8c33f18fdc754804c459f088c8af9624815eacb054516a060d55ce4583
+EBUILD lgogdownloader-3.4.ebuild 617 BLAKE2B 8499d5fb46d6de4b7e38b47a6ba974c11c94644932dc58fcdc4e889ee93a24ae848247316accb3da7c833c507c18b5456d15f08a29074a8846f0710f78bf19a3 SHA512 15091e8b08dd0c6ea416da746c11b27848d2ecfecf9f87fa41e921956385291d571d05e7d19544bce1a4ce2412eabf91c7865a161b163d04bf8ddb11570be85b
EBUILD lgogdownloader-9999.ebuild 595 BLAKE2B 6952d20f49e8de4192580f817ed40ed75e9b4b4350ca4386d3ae833d7754ce64229dad443d65c8bbf16e97d5cce5aef9bdcb0e9b78f5e58c26d90f052ac82051 SHA512 96abd62dd1be6f345ea2aeae400c843eff0e68caa38bfed0e38b7fdd09957dfa170b988886a2144066c545e05845604d54af31d05f622ea1346c520f80f048ac
MISC metadata.xml 1009 BLAKE2B 4a7828bf14d896ea37cc6091c2d019bb96e4c97e0ae3f2b48045a92aa9ec2a648058fe817b5cc0fc2bb98379365b9d94f9529ba5de1b3f5dca67dcb313f87cb9 SHA512 cc64f740c4b3ab4a5c4d87b60b2146b6b5a64869d19f6283428d365c7a6f79a6697b8bd63bd31c2cad63bb065d32ac751c643ff794adf966edfc8663debdd4af
diff --git a/games-util/lgogdownloader/lgogdownloader-3.3.ebuild b/games-util/lgogdownloader/lgogdownloader-3.4.ebuild
index 0ac33eae5786..213bca2a9420 100644
--- a/games-util/lgogdownloader/lgogdownloader-3.3.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6