summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
commit7d040c2d1b0c38c8635ec28dfaa632a2db8be895 (patch)
tree78e9474cad949bcd1254749d61f4f6b9e7d488bf /games-util
parent0d39cf7bd8aae36b5d8eb4272a42dc6919216e34 (diff)
gentoo auto-resync : 11:04:2023 - 23:39:54
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7869 -> 7866 bytes
-rw-r--r--games-util/sc-controller/Manifest2
-rw-r--r--games-util/sc-controller/files/sc-controller-0.4.8.9-python3_11.patch24
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.9-r1.ebuild57
4 files changed, 83 insertions, 0 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index 7a2e499596a9..7492799a28ff 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index 16ce5d020902..2d118253858b 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1,3 +1,5 @@
+AUX sc-controller-0.4.8.9-python3_11.patch 744 BLAKE2B 4cbaafa7f941e9e2135883fd7ae60519b70a76e5e0a3d9cabde9b087ad9d13c931220a6f2c7a6b6dce84ad5a3e940779ad50367a1e697cf689484d0150339210 SHA512 6e786253236db297bd1b169a7a6db1f44fb8485f8f4361113b3116aad95e17c51fdd72082c5dd45b30115fdef380b8482389b71470f4c2911ee778b42257538b
DIST sc-controller-0.4.8.9.tar.gz 2541647 BLAKE2B f4e4ebcd15f8c32f292293ea21a0c30655fedefba310991082ece3b9159b52700178a31da4b3e7a172e40fde4e718403c0945387f3781628e09fa1fc086eee93 SHA512 e0848d366f6f80c36670adcda717b792b6993e7383c01e969c0478cf187bcdb891ea9c434271f24e7f5dfc96d8f321f953f610bb8efeb6ed843b7cd069b9b18f
+EBUILD sc-controller-0.4.8.9-r1.ebuild 1412 BLAKE2B 197ed2ff20d66a501f0777524e0cc733cdaa8febdbfed787dd693ae37d8b435ca453feea35234df859326caec45cbfdc645b8db1111d1b843605b6e38ac096be SHA512 b94e43cda44bb28b903caf7018319c6ea56e3f488c2a38df7ae3944ada6b1f034418adf7de1a3cbc5467911915b7280c1d99c5b1bf8f77847d7914b03f8ba167
EBUILD sc-controller-0.4.8.9.ebuild 1309 BLAKE2B 4ad7caedf7b2385458e28265708bbcf034b2ef015c5b8adc77aca5a7a34cd41d20a47cd197604d09c0ee275f21e4be9210d66b6cf224dcbdf0431dc23b0fd5e1 SHA512 03fb3d48fbe922574a2cafd3ce3f841eb987ff8c9fcecdedb91087e27a1964b6fe989f47737d2d5dd8d2803279522b82e211a7d243ac8c7f71830d9d9d3ee572
MISC metadata.xml 341 BLAKE2B 8bfad400d398e07b5c8ba2c0a54c3fb3768d6748df641c4d2ad75a8032fd7f351f023acf791b9b61da0e70500cfdb1b669eaaa140f6351a851b6b2e23d3c5147 SHA512 4f17d6bd17da51eec7d7b90a3c72b9ef29bb6780dc4b67245ca4ce17a62128eb800ae1e519d2b136763c3c26cf89473fb23a7e878c1e4b19b116ed9546547f58
diff --git a/games-util/sc-controller/files/sc-controller-0.4.8.9-python3_11.patch b/games-util/sc-controller/files/sc-controller-0.4.8.9-python3_11.patch
new file mode 100644
index 000000000000..283dbba8be98
--- /dev/null
+++ b/games-util/sc-controller/files/sc-controller-0.4.8.9-python3_11.patch
@@ -0,0 +1,24 @@
+diff --git a/scc/lib/__init__.py b/scc/lib/__init__.py
+index 33d1486dd..0fe3141a5 100644
+--- a/scc/lib/__init__.py
++++ b/scc/lib/__init__.py
+@@ -1,3 +1,3 @@
+ #!/usr/bin/env python2
+
+-from enum import Enum, IntEnum, unique
++from .enum import Enum, IntEnum, unique
+diff --git a/tests/test_strings/test_keys.py b/tests/test_strings/test_keys.py
+new file mode 100644
+index 000000000..f118d373c
+--- /dev/null
++++ b/tests/test_strings/test_keys.py
+@@ -0,0 +1,8 @@
++from scc.uinput import Keys
++from scc.lib import IntEnum
++
++class TestKeys(object):
++ def test_up_str(self):
++ assert isinstance(Keys.KEY_UP, IntEnum)
++ assert Keys.KEY_UP.name == "KEY_UP"
++ assert str(Keys.KEY_UP) == "Keys.KEY_UP"
+\ No newline at end of file
diff --git a/games-util/sc-controller/sc-controller-0.4.8.9-r1.ebuild b/games-util/sc-controller/sc-controller-0.4.8.9-r1.ebuild
new file mode 100644
index 000000000000..6c49de8ca581
--- /dev/null
+++ b/games-util/sc-controller/sc-controller-0.4.8.9-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 linux-info xdg
+
+DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
+HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
+SRC_URI="https://github.com/Ryochan7/sc-controller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD CC-BY-3.0 CC0-1.0 LGPL-2.1 MIT PSF-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+udev wayland"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]')
+ gnome-base/librsvg[introspection]
+ virtual/libusb
+ x11-libs/gtk+:3[introspection]
+ udev? ( games-util/game-device-udev-rules )
+ wayland? ( gui-libs/gtk-layer-shell[introspection(+)] )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/Ryochan7/sc-controller/pull/82
+ "${FILESDIR}/${P}-python3_11.patch"
+)
+
+pkg_setup() {
+ local CONFIG_CHECK="~INPUT_UINPUT"
+
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # This test fails. Don't know why but seems unimportant.
+ rm -v tests/test_glade.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ rm -r "${ED}"/usr/lib/udev/ || die
+}