summaryrefslogtreecommitdiff
path: root/games-util/xpadneo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /games-util/xpadneo
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'games-util/xpadneo')
-rw-r--r--games-util/xpadneo/Manifest4
-rw-r--r--games-util/xpadneo/xpadneo-0.9.1.ebuild38
-rw-r--r--games-util/xpadneo/xpadneo-9999.ebuild35
3 files changed, 49 insertions, 28 deletions
diff --git a/games-util/xpadneo/Manifest b/games-util/xpadneo/Manifest
index 4da7ce491fcb..bc13258c82aa 100644
--- a/games-util/xpadneo/Manifest
+++ b/games-util/xpadneo/Manifest
@@ -1,4 +1,4 @@
DIST xpadneo-0.9.1.tar.gz 1353080 BLAKE2B fc2207e005cae629da50048330cbaa7d27183b0bbb083d35c3c144e91470273b8c7006c4b62d10b947dbe4fd003ca39623630923e477aa4eff3c243405d876bd SHA512 51063d104f165018b8430e26d2ab5a622c214efaaba3f7706cc99892b2054f57667b419672de5c2696189d389401b07024658c36a88343d980de9802789bcb10
-EBUILD xpadneo-0.9.1.ebuild 1765 BLAKE2B 91965729167f626fe1e0b6ac5093b1bf94e436f5f518b8b1a84eacd0c90bfbef7e70bbefb48e85484cf03aceccc026b64e3c3c518ab514539f0088f3047ef131 SHA512 bf67407c56cc8ce7906fe4b45129173e6e8b2692e6c3cc26405cc1988917de734f95079364c325e7f131071cd56d7f2d8aeea3856e327be27692188ab8f04bce
-EBUILD xpadneo-9999.ebuild 1765 BLAKE2B 91965729167f626fe1e0b6ac5093b1bf94e436f5f518b8b1a84eacd0c90bfbef7e70bbefb48e85484cf03aceccc026b64e3c3c518ab514539f0088f3047ef131 SHA512 bf67407c56cc8ce7906fe4b45129173e6e8b2692e6c3cc26405cc1988917de734f95079364c325e7f131071cd56d7f2d8aeea3856e327be27692188ab8f04bce
+EBUILD xpadneo-0.9.1.ebuild 2423 BLAKE2B c1cb53c426940bc3b079c21cb54f5e33a67094bc36dd83ce14063ca1c20f804ebe32640b8670f0542c234d1dea3330c530ae817da12a99482dbb236002e9efe4 SHA512 09792a7fc3eea09162f9facfe85821855840001339ffe366032c988d6a45e6e1dfc837a59b8b8018b4056edf2894bec0978f1bcf92946e81bcc4ac0117c8bc76
+EBUILD xpadneo-9999.ebuild 2253 BLAKE2B 217187d9a9dbde2bff73d2115da5e7057f60bdfc9569cab7f37bce0f6dad3e643e34d8d00fa01a380e4383dafdd6fda53fa3bf7cc3ba3b2345ac975386dae218 SHA512 4e55be1b24232651d10bbf89a523081d1ce79521a58ffc83c95435577dbc79dc52671b1354fcaf663ceff0cdb305aa8c24caf04128f26bde1c06ea415fd3409b
MISC metadata.xml 476 BLAKE2B 88a9a4d49f902c50d87fe36c98f6f4f2c553c6cb6882966f0d4858413ed8b603f428c7b3b43d157a6ff25fb1ab26231657119e14b4a0260a159a372501593391 SHA512 9f3a4e2063cb3e30b8ba428930715533c0c3fe7defda881d1a86f5f652fc736938e88ce21e4f028f57f9edc14f6528c8a731a6689242c0d369f44a2606425fd7
diff --git a/games-util/xpadneo/xpadneo-0.9.1.ebuild b/games-util/xpadneo/xpadneo-0.9.1.ebuild
index 75edf29d3954..bf7685af800c 100644
--- a/games-util/xpadneo/xpadneo-0.9.1.ebuild
+++ b/games-util/xpadneo/xpadneo-0.9.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-mod toolchain-funcs udev
+inherit linux-info linux-mod toolchain-funcs udev
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -36,25 +36,37 @@ src_install() {
udev_dorules etc-udev-rules.d/60-${PN}.rules
dodoc -r ../docs/{[^i]*.md,descriptors,reports} ../NEWS.md
+ newdoc ../misc/kernel_patches/0001-fix_bluetooth_reconnect.patch \
+ L2CAP-fix-for-kernel-5.11-or-older.patch
}
pkg_postinst() {
linux-mod_pkg_postinst
udev_reload
- local ertm=/sys/module/bluetooth/parameters/disable_ertm
- if ! [[ ${REPLACING_VERSIONS} && $(<${ertm}) == Y ]]; then
+ local disable_ertm=/sys/module/bluetooth/parameters/disable_ertm
+ if kernel_is -ge 5 12; then
+ if [[ $(<${disable_ertm}) == Y ]]; then
+ elog "Warning: bluetooth ERTM (Enhanced ReTransmission Mode) is disabled."
+ elog "This is no longer recommended with kernel >=5.12 to use ${PN}."
+ elog "Can remove ${EROOT}/etc/modprobe.d/no-ertm.conf if it exists, and run:"
+ elog " echo N > ${disable_ertm}"
+ elog "After changing, may need to re-pair the gamepad with bluetooth."
+ fi
+ elif [[ $(<${disable_ertm}) == N ]]; then
+ elog "Warning: bluetooth ERTM (Enhanced ReTransmission Mode) is enabled."
+ elog "While keeping enabled is recommended for rumble usage stability, it can"
+ elog "cause connection issues without kernel >=5.12 or the L2CAP kernel patch"
+ elog "provided in ${EROOT}/usr/share/doc/${PF}/"
+ elog "If needed, this mode can be disabled by running:"
+ elog " echo Y > ${disable_ertm}"
+ elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
+ elog "After changing, may need to re-pair the gamepad with bluetooth."
+ fi
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "To pair the gamepad and view module options, see documentation in:"
- elog " ${EROOT}/usr/share/doc/${PF}"
- elog
- elog "Be warned that bluetooth's ERTM (Enhanced ReTransmission Mode) can"
- elog "cause the gamepad to enter a re-connection loop."
- elog "- To disable immediately:"
- elog " echo Y > ${ertm}"
- elog "- To disable for next and subsequent boot:"
- elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
- elog "- Or, if bluetooth isn't a module, add to the kernel's command line:"
- elog " bluetooth.disable_ertm=y"
+ elog " ${EROOT}/usr/share/doc/${PF}/"
fi
}
diff --git a/games-util/xpadneo/xpadneo-9999.ebuild b/games-util/xpadneo/xpadneo-9999.ebuild
index 75edf29d3954..6ee1277444a5 100644
--- a/games-util/xpadneo/xpadneo-9999.ebuild
+++ b/games-util/xpadneo/xpadneo-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-mod toolchain-funcs udev
+inherit linux-info linux-mod toolchain-funcs udev
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -42,19 +42,28 @@ pkg_postinst() {
linux-mod_pkg_postinst
udev_reload
- local ertm=/sys/module/bluetooth/parameters/disable_ertm
- if ! [[ ${REPLACING_VERSIONS} && $(<${ertm}) == Y ]]; then
+ local disable_ertm=/sys/module/bluetooth/parameters/disable_ertm
+ if kernel_is -ge 5 12; then
+ if [[ $(<${disable_ertm}) == Y ]]; then
+ elog "Warning: bluetooth ERTM (Enhanced ReTransmission Mode) is disabled."
+ elog "This is no longer recommended with kernel >=5.12 to use ${PN}."
+ elog "Can remove ${EROOT}/etc/modprobe.d/no-ertm.conf if it exists, and run:"
+ elog " echo N > ${disable_ertm}"
+ elog "After changing, may need to re-pair the gamepad with bluetooth."
+ fi
+ elif [[ $(<${disable_ertm}) == N ]]; then
+ elog "Warning: bluetooth ERTM (Enhanced ReTransmission Mode) is enabled."
+ elog "While keeping enabled is recommended for rumble usage stability, it can"
+ elog "cause connection issues without a fix included in kernel >=5.12"
+ elog "If needed, this mode can be disabled by running:"
+ elog " echo Y > ${disable_ertm}"
+ elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
+ elog "After changing, may need to re-pair the gamepad with bluetooth."
+ fi
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "To pair the gamepad and view module options, see documentation in:"
- elog " ${EROOT}/usr/share/doc/${PF}"
- elog
- elog "Be warned that bluetooth's ERTM (Enhanced ReTransmission Mode) can"
- elog "cause the gamepad to enter a re-connection loop."
- elog "- To disable immediately:"
- elog " echo Y > ${ertm}"
- elog "- To disable for next and subsequent boot:"
- elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
- elog "- Or, if bluetooth isn't a module, add to the kernel's command line:"
- elog " bluetooth.disable_ertm=y"
+ elog " ${EROOT}/usr/share/doc/${PF}/"
fi
}