summaryrefslogtreecommitdiff
path: root/games-util/xboxgw/xboxgw-1.082.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/xboxgw/xboxgw-1.082.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/xboxgw/xboxgw-1.082.ebuild')
-rw-r--r--games-util/xboxgw/xboxgw-1.082.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-util/xboxgw/xboxgw-1.082.ebuild b/games-util/xboxgw/xboxgw-1.082.ebuild
new file mode 100644
index 000000000000..ef0a637ca80a
--- /dev/null
+++ b/games-util/xboxgw/xboxgw-1.082.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+XBOXGW_P="${PN}-1.08-2"
+HMLIBS_P="hmlibs-1.07-2"
+
+DESCRIPTION="Tunnels XBox system link games over the net"
+HOMEPAGE="http://www.xboxgw.com/"
+SRC_URI="http://www.xboxgw.com/rel/dist2.1/tarballs/i386/${XBOXGW_P}.tgz
+ http://www.xboxgw.com/rel/dist2.1/tarballs/i386/${HMLIBS_P}.i386.tgz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+QA_PREBUILT="opt/${PN}/lib/libhmdb.so
+ opt/${PN}/lib/libhmsched.so
+ opt/${PN}/lib/libhmcli.so
+ opt/${PN}/lib/libhmsdb.so
+ opt/${PN}/bin/hmdbdump
+ opt/${PN}/bin/xboxgw
+ opt/${PN}/bin/xbifsetup"
+
+S=${WORKDIR}
+
+src_install() {
+ into /opt/${PN}
+
+ cd "${WORKDIR}/${HMLIBS_P}"
+ dolib.so *.so
+ dobin hmdbdump
+ insinto /usr/include/hmlibs
+ doins *.h
+
+ cd "${WORKDIR}/${XBOXGW_P}"
+ dobin xboxgw xbifsetup
+ dodoc *.txt
+
+ if use amd64 ; then
+ mv "${D}"/opt/${PN}/lib64 "${D}"/opt/${PN}/lib || die
+ fi
+}