summaryrefslogtreecommitdiff
path: root/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild')
-rw-r--r--games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
new file mode 100644
index 000000000000..0a8fbabae6b4
--- /dev/null
+++ b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+WX_GTK_VER="3.0"
+inherit eutils wxwidgets
+
+DESCRIPTION="A program to decode .CHT files in Snes9x and ZSNES to plain text"
+HOMEPAGE="http://games.technoplaza.net/chtdecoder/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wxgtk.patch
+}
+
+src_configure() {
+ econf --with-wx-config=${WX_CONFIG}
+}
+
+src_install() {
+ dobin source/wxchtdecoder
+ dodoc docs/wxchtdecoder.txt
+}